Starcraft 2 Nova from Covert Ops Model

Hi!

Did anyone extract the model from Starcraft 2 Covert Ops of Nova yet or is willing to give it a go? I cannot find a model of Nova from Covert ops anywhere. If someone has done so, please link me. I know since Blizzard changed their model format, people weren’t able to figure out how to rip the model.

FYI, Nova from the original Starcraft is different from the Covert Ops model. The old SC2 models extraction thread has been quite dead for a bit unfortunately.

Thanks!

If you have the datafile for the mission pack, I can try extracting it from it. I doubt it’s too different from the LoTV model format.

I actually think I figured it out, my only problem is I can’t find Nova’s face.

Try grabbing it out of the portrait if nothing else works.

I’m curious with how this is coming along. I extracted her files using the editor and tried converting to obj. I think it ends up with broken UVs. I’m going to try extract again but with Casc Viewer.

maybenexttime : Her face should be under ~ \Assets\Textures\smx3_nova_head_diff.dds

wraithcat : Do you know of any updated import/conversion tools for m3 files? I tried using SCII Art Tools for 3ds (can’t get it to work), blender m3 import doesn’t work. 3ds m3 import script only works when I disable bones and materials but it only imports the armor sections.

Thanks.

I couldn’t get from the files maybenexttime sent me. As to what I use for m3s. I find that the old tools sometimes work better for portrait models if you disable rigging as the newer tools just crash.

Thanks. I’ll have to play around with the tools some more I guess.

When you tried to import were you able to fully import the model or just get armor parts like I did?
https://s31.postimg.org/uaj0e701z/3ds_import.jpg

Here’s an example of the converted obj I mentioned earlier:
https://s31.postimg.org/3qqfc1zif/blender_obj.jpg

And the UVs:
https://s31.postimg.org/xjxfkno5j/UV_armor.jpg https://s31.postimg.org/704uiinlz/UVs.jpg

It’s possible they’ve resorted to using multiple UVW sets - one for standard textures and another for lightmaps. Though unsure.

Could be. But we are already beyond my capabilities/understanding.

Here’s a couple of my progress notes:
.M3 blender and max import scripts don’t work for me (I tried several versions to no avail)
Blender gave me an error referring to one of the materials.
Max only imported parts of the armor and only after all other options were pretty much disabled.

-I had tried several different versions of the 3D model viewer (Xentax) to convert to obj, eventually I got an OBJ that could be imported into Blender without errors.
https://s9.postimg.org/c0rypa0gr/6_types.png

-From the 6 nova models only one of the converted obj’s had proper UV’s on load - the SMX3_Nova_Cloak
https://s9.postimg.org/ntud78maj/Nova_Cloak.jpg

-The SMX3_Nova_FullCloaked was off but could be adjusted (blender: size was x:4.90 y:4.90 z:1.00)
https://s9.postimg.org/a1fyblviz/Nova_Full_Cloak.jpg

The others have the messed up UV’s and need work beyond what I’m capable of doing. I’ll probably post the obj’s over the weekend to see if anyone else has better luck.

-In order to see textures (face, armor, etc)- I needed to turn off the alpha:
https://s9.postimg.org/3wofya3ff/alpha.jpg

-More of a side note - the model uses additional textures that are shared by other models:
https://s9.postimg.org/c3gfputi3/hex.jpg

As promised, I zipped a couple of converted obj’s and textures along with the original SMX3_Nova.m3.

I know for a fact that I’m not the only one with import and UV issues. Looks like the m3 was changed. Pity the SC2 modding community is almost dead, otherwise this would have been out a long time ago.

Wraithcat maybe you can make heads or tails of it.

SC2_Nova.zip

Could someone upload the covert ops Nova again? or PM me the link?

Through sheer dumb luck I got an M3 script to work in max 2011. Script credit due to Taylor Mouse.
https://www.sc2mapster.com/projects/sc1-raynor-vulture/files/2372418

Newest Iteration: http://www113.zippyshare.com/v/87Ycp0jF/file.html

Cleanest file will be under SC2_Nova>Nova New Exports>Nova Max File as that was the best & most recent import I ever got & saved. The rest were just other attempts that I’m keeping for posterity. Still got issues with UV’s but it should be much better.