Startup problem

ok ive had gmod workin great for about a week, but today wen i tried to open it, this showed up:

The instruction at “0x3810c774” referenced memory at “0x00000010”. The memory could not be “read”. Click Ok to terminate the program.

can anyone tell me how to fix this?
and ive already re-downloaded it and still the same prob

Close some background applications and try again.

kk
tried it still the same prob

Open Run, then type in “dxdiag” and hit enter. In the window it opens, tell us what it says next to “Memory”.

1020 mb ram

That’s not a lot.

Garry’s Mod needs at least 1GB (1024MB) of RAM to work properly, and you’d still need some memory left over to run background programs that the computer needs.

If you’re using a desktop, buy some more RAM, but first get someone you know is good with computers to take a look at your PC and see what kind of RAM you need.

If you’re on a laptop, I suggest it’s time to upgrade. You’d be looking for one with at least 2. Personally I recommend 4GB, but obviously that would cost more.