Static Tree Model issue.

I’ve made a tree model, only problem is that the opacity appears in game, but the map light compiler seems to think differently.

[img_thumb]http://img529.imageshack.us/img529/5622/1024office0000.jpg[/img_thumb]
Is what I’m getting.

How would I go about achieving this effect with my model?
[img_thumb]http://img21.imageshack.us/img21/9738/1024office0001.jpg[/img_thumb]

If anybody could write me a guide to it would be nice since I’m fairly new to modeling.

Have you compared the .vmt of the texture of that episode 2 tree to yours?

Yes.

Mines not uvmapped though. 2 separate textures. leafs are;


"VertexlitGeneric"
{
	"$basetexture" "models/props_foliage/leaf01"
	"$alphatest"	"1"
	"$nocull" "1"
	"$model" "1"
}

And having $model at 0 doesn’t seem to help either.

~ZOMG I know you know that I know how to make .VMTs :v:

It’s actually more directed at the mapping forum, but this gives the answer

YOu need to modify the rad file

Incredibly hood find, thankyou Wraithcat.

Did it already.

Trust me I know how to map and what needs to be done with it, though I think this is a model error, rather a mapping one because it does the same thing in max.

VertexLitGeneric is for models only, so the models flag is not necessary.

And have you tried $translucent instead of $alphatest?

Yes.

DOES YOUR TEXTU-

does your texture have a 2-bit alpha channel? source doesn’t support 8-bit.

(fucking capslock magically activating)

Not sure.

[editline]12:39PM[/editline]

http://www.mediafire.com/?dqdyauxetkf0y97
Here is my texture.

Try $opaque or $mostlyopaque in your qc

i mean when you compile the .vtf using vtfedit you select one of the 2bit alpha compressions.

Compile with -TextureShadows, bro.

Done both.

[editline]05:23PM[/editline]

I’ll try the 2 bit thing. Though valves models have the 8 bit alpha.

Have you tried doing a full compile on the map? I think quick compiles skip steps like texture-alpha raytracing.

I did. Look at the op I compiled the map myself with the pine tree.

Both pictures are in source.