Steam doesn't recognize my gmod?

Okay, so today, when i tried to get on my GMOD, steam just wanted to reinstall it, but i have it on my computer, its not recognizing it, no its not an update, i changed the background and went into the game and it didnt change, tried serveral things… but here some pictures.

The FUCK is up with your garrysmod/garrysmod folder? It looks like something (addon) got installed wrong, but it doesn’t explain the dod, and hl2mp folders. It also looks like you got some CSS folders in there.

Best thing to do: Delete the game. Do a fresh install.

also direct non-exported svn’s…
You should reinstall

Lol, okay. i’ve had this account since 08,
but what im saying guys, is that garrysmod folder that i just showed you, is NOT the gmod that its starting up.
its not in my old steamapps/garrysmod folder, its somewhere else. Where would it be installed on vista?

OKAY
I figured out where steam installed the NEW garrysmod, it was in TortoiseSVN\steamapps\garrysmod
I dont know why, but… whatever. thanks guys! ;D