Steam overlay problem in Rust.

Hi everyone. I have 1920x1080 monitor, but i’m playing in 1024x768 resolution, cause of better fps and wide heads. I’m also recording my gameplay with bandicam.
After latest updates of Rust or Steam, overlay is now equal to my desktop resolution. Now when i’m trying to record video it’s not 1024x768 but 1920x1080.
My PC can’t handle recording in fullhd so everything stuttering and i have very low fps. Also it doesn’t matter anymore in which resolution i start Rust - it’s always fullhd, so fps is much lower.
In CS 1.6 update there was a problem exactly like this and there was a solution - adding -nofbo to launch parameters. Is there any solution for Rust?
First screenshot is what it was like, second - what’s now. Both of them should be 1024x768.
http://i.imgur.com/xDyiwgb.png http://i.imgur.com/T4VSBOT.png

Buy a better rig?

What happens if you don’t play in full-screen and with the overlay disabled?

Why are you recording? I don’t get why everyone and their mother feels the need to record every little thing. I can guarantee you this: YouTube doesn’t care.

If you really must record then get a better computer that can handle doing it in your native resolution. How do you even play in 1024x768? That sounds like torture.

Otherwise our group is banned on most servers within a few hours. 1024x768 is just fine for me, habit since 2001. I have 780Ti and i74770k, so there’s no problem for me to play in native resolution. I just like to have at least 100 stable fps (120 is just perfect) for 120hz monitor. I’m asking if anybody knows a parameter to fix this, that’s all.

With a GTX 780Ti you should be running ~150fps at 1920x1080. If you have to dumb down your settings to get 120fps with that graphics card and a quadcore 3.90ghz Processor, then something is seriously wrong with your setup.

I’m running a GTX 760 on 1920x1080 and I average ~110fps.

Maybe, but that’s not the point. Question still not answered.