STEAM validation rejected.. wat

So I was going to join a server, and then that message popped up, and then I was ganna join another server, and that message popped up. Whenever I try to join a server, that message pops up :saddowns:

Help

Restart Steam

You DID buy GMod, right?

If you did, also try reinstalling GMod if just restarting Steam doesn’t work.

Reinstalling wont help a shit, delete ClientRegistry.blob (in main steam folder) if restarting steam dosent work

Checklist:
Did you get a downloaded copy of GMOD?
Have you tried verifying GMOD?
Do what Tobba tried if all fails.

[editline]05:09PM[/editline]

If you illegally downloaded GMOD, go away.
If you have GMOD9, go away

No shit, he bought retail. :downs:

If you checked his steam link under his avatar, that would answer some of your questions.

Before asking a question like did you buy gmod you should check his Steam profile where the game is clearly listed in his games list…

Restarting Steam should do the trick.

facepalm

I forgot those things were even there. Sorry for insinuating, OP.

Thank you. You saved me a headache.

Restarting steam worked.

Mods can now lock, thank you :v: