SteamCMD gmod server, no props breaking into gibs

Ok so this is really weird. I’m working on a prophunt map, so I set up a local server in a vm. Everything is working just fine, except when you break a prop such as a glass bottle or the TV from cs_office, it instantly disappears. No broken parts.

Here is a video showing this: https://www.youtube.com/watch?v=yjmpKPp_Kjg

I’ve talked to a couple of people who own gmod servers and they are stumped. Nothing on google about this or being able to disable gibs.

Anyone here have any idea what this could be? Really frustrated with it as I thought it was my map for the last two days and I have been tearing my hear out over it. Turns out it happens in any map on the server in any gamemode.

Try these.

None of those had any affect at all :frowning:

When trying to test antlion gibs I also discovered that explosions aren’t working correctly. Almost like the grenades are out of the world: https://www.youtube.com/watch?v=OiIlB5NAxuE

[editline]16th October 2014[/editline]

I should also mention, it only happens on the server, single player is fine.

The server only has css content and the prop-hunt gamemode from github

Isn’t that supposed to happen with PropHunt? I thought that was supposed to happen in PropHunt…as for the odd grenade issue, I have no clue.

Nope prop hunt should have gibs. Either way, the two videos I posted were with the server in sandbox just to make sure

Gibs require HL2 I’m pretty sure, is that installed on the server?

EDIT: Just realized those are CS:S props, but you should install every source game on the server just in case.

Just for the mechanic though? Because I can spawn the actual gib models perfectly fine

[editline]16th October 2014[/editline]

HL2 installed. No change, even the HL2 ammo crates break with no gibs.

Reinstalled garrysmod on the server, still the same issue. Configured from scratch with no mods

Maybe the server is confused because when you kill a player prop there is no gibs left. Try going on maybe cs_office and try it out (By destroying cs_office’s props)

If you watch this video in my OP: https://www.youtube.com/watch?v=yjmpKPp_Kjg

You will see that I am on gm_construct shooting cs_office props as well as half life props.

Interesting update.

I ended up installing the gmod server new in steamcmd.

After installing, without editing the config I started the server and connected.

Grenades worked just fine.

I copied my old server.cfg to the newly installed server and started it again.

Grenades no longer worked.

WTF there is nothing in my config that can be causing this. (as far as I know)

I used this site to generate my config: http://gmod-servercfg.appspot.com/

Here is my complete config:



//Garry's Mod server.cfg - Autogenerated with http://robinschoors.com/?p=244
logging                 on
hostname                "-gmod"
rcon_password           "asdf"
sv_password             "asdf2"
sv_region               255
sv_lan                  0
sv_logbans              1
sv_logecho              1
sv_logfile              1
sv_log_onefile          0
sv_noclipspeed          5
sv_noclipaccelerate     5
//Sandbox Settings
sbox_allownpcs          1
sbox_godmode            0
sbox_plpldamage         0
sbox_playergod          0
sbox_noclip             1
sbox_maxprops           150
sbox_maxragdolls        5
sbox_maxnpcs            10
sbox_maxballoons        10
sbox_maxeffects         50
sbox_maxdynamite        10
sbox_maxlamps           20
sbox_maxthrusters       30
sbox_maxwheels          20
sbox_maxhoverballs      20
sbox_maxvehicles        6
sbox_maxbuttons         20
sbox_maxsents           20
sbox_maxemitters        5
sbox_maxspawners        3
sbox_maxturrets         2
//Server Settings
net_maxfilesize         30
decalfrequency          10
sv_defaultgamemode "sandbox"
//Execute ban files
exec banned_ip.cfg
exec banned_user.cfg
sv_minrate 3500
sv_maxrate 0
sv_minupdaterate 20
sv_maxupdaterate 0
sv_downloadurl"http://192.168.2.203/"
sv_allowupload "0"
sv_allowdownload "0"


Anyone have any idea what is causing this? I can’t find anyone on google having this problem? Video on the server with the only thing changed being the config I posted above: https://www.youtube.com/watch?v=RSsvhmACAQg

Fixed it! The problem was this line:



sv_maxupdaterate 0


I commented out line by line till I got to that one which made it work.

Looked up what that command did and ended up changing it to 60. Now my props break!