Steamcmd server problem

When I enter my server

“the server you trying to connect is running a newer version of the game”

what’s this?

It’s because the regular version of GMod has not been switched over to steampipe yet, you will have to opt in to the beta to connect.