Still having a Gmod Problem

Hello everyone,
It seems Garrysmod has broken for me for the first time in all of my Gmod history. What happens when I try to join servers, right at “Sending Client info” I get an error thats somewhere along the lines of:

Not sure if it’s exactly that, but original post was: http://www.facepunch.com/showpost.php?p=16045477&postcount=49

The numbers might be different, although here is what I have tried:
– Reinstalled Gmod, 1st time kept addons and data, 2nd time delete everything, 3rd time redownloaded GCF.
– The TF2 non-loading additional content in gcf/content.txt
– -dxlevel (Any) has no effect whatsoever

Garrysmod has worked flawless for the past half year, then yesterday I quit out to download a Combine Sniper addon and all of the sudden Garrysmod blew up in my face. I can deal with having no more Expression 2’s, or Advanced dupes but not being able to play the game on any server is beyond me. Any help would really be appreciated, also reformatting really isn’t a necessary option for this as every other game works fine.

Thanks,
Bastinka

EDIT:
Reinstalling again with deleting the Local Game Content (Re-downloading Garrysmod) for the second time. I also tried disabling all additional content.

[editline]11:37AM[/editline]

Reinstalled twice again, one time with local content deleted. The other time with deleting all the garrysmod files whatsoever.

Still gives me that weird error, has anyone got any clue?

EDIT: If you find anything at all, please suggest it if I have not tried it. Also to anyone having the same problem:
http://www.facepunch.com/showthread.php?t=582390

Hop on the bandwagon.

http://img190.imageshack.us/img190/641/gmconstruct0000m.jpg

Now my singleplayer works, but looks really weird. Lightmaps are all bright and the health and scoreboard are weird.

Note: I’ve tried palying CS: Source, Half Life 2, Half Life 2 Death Match and Portal. All of these work perfectly fine as they used to. I even uninstalled TF2 and unmounted all additional’s except Half Life 2 in Garrysmod.

[editline]02:23PM[/editline]

For the moment, and oddly enough -dxlevel 95 just started working.

Thats my temporary fix. Gonna try loading all modules other then TF2.

-dxlevel 95 doesn’t work. It only goes up to 90.

Also, if I were you, I’d try to keep that scoreboard, it looks AWESOME.

Maybe the Combine Sniper is broken, are you 100% sure you got rid of it? (Or am I misreading a line)

IM HAVING EXACTLY THIS PROBLEM but only in all but my gooniverse map, and in all my others i can wal karound just fine and even go out in to space but i dont, even tho i have the addon, get the box at the bottom of the screen, and then i go to spawn my adv_dupe spaceship and the moment i hit q i get:
The memory could not be “read”. what the hell did garry do?

people are still having this problem 2 years later