Stranded gamemode dosn't work when unpacked.

When i run the stranded gamemode downloaded right from the workshop it works perfectly, but whenever i unpack it with the GMAD tool, most of its functions don’t work. I also asked my friend to upload his gamemode folder (which works for him) and it doesn’t work for me. The HUD works, but everything else doesn’t. I get the console error when i set up singleplayer:


[ Simple Prop Protection ] 211 props belong to world

Nav File is wrong or something (1)
Garry's Mod

gmstranded
gms_rollinghills_daynight_g6
1
76561198145991535
clientside lua startup!
Failed to load custom font file 'e:/steam/steamapps/common/garrysmod/garrysmod/resource/fonts/bebasneue.ttf'
Failed to load custom font file 'e:/steam/steamapps/common/garrysmod/garrysmod/resource/fonts/opensans-condbold.ttf'
Failed to load custom font file 'e:/steam/steamapps/common/garrysmod/garrysmod/resource/fonts/opensans-condlight.ttf'
Failed to load custom font file 'e:/steam/steamapps/common/garrysmod/garrysmod/resource/fonts/opensans-regular.ttf'
Failed to load custom font file 'e:/steam/steamapps/common/garrysmod/garrysmod/resource/fonts/ultra.ttf'
Attempted to create unknown entity type gms_fists!


When i try to set up a structure i get an error:


Attempted to create unknown entity type gms_buildsite!

[ERROR] addons/gmstranded/gamemodes/gmstranded/gamemode/init.lua:322: Tried to use a NULL entity!
  1. SetAngles - [C]:-1
   2. CreateStructureBuildingSite - addons/gmstranded/gamemodes/gmstranded/gamemode/init.lua:322
    3. OnStop - addons/gmstranded/gamemodes/gmstranded/gamemode/processes.lua:1221
     4. StopProcess - addons/gmstranded/gamemodes/gmstranded/gamemode/processes.lua:80
      5. unknown - addons/gmstranded/gamemodes/gmstranded/gamemode/processes.lua:59

Timer Failed! [GMS_ProcessTimer_1][@addons/gmstranded/gamemodes/gmstranded/gamemode/processes.lua (line 59)]


So, long story short - gamemode downloaded from workshop works, when i unpack the gamemode it doesn’t work, also a friend sent me his gamemode files which are modified and those still don’t work.

You have missing entities that you didn’t get from the extraction.

There’s a bug with the folder addon system where gamemode entities/weapons/etc will not load.

Is there any way fix or bypass it?

Put everything in your root folder and not addons/

To clarify, this means move the folder addons/gmstranded/gamemodes/gmstranded to root/gamemodes, and not the addons/gmstranded folder

It worked, thank you both a lot!