Strange "click-through" bug when selecting entities

I’ll let the video I took do the explanation:

Have you tried verifying files yet? Or re-installing Source SDK? When did this bug start?

The video doesn’t nearly give all the info we need to properly help you.

Is your mouse lined up with everything else like the main window/drag in another window. Try keeping the editor out of the fullscreen just double click the top and see if keeping it floating fixes it.

Make a thread about it.

Go to tools>options>3d and untick reverse selection order.

That seemed to be it, though I have no idea how that option got selected in the first place.

Thanks.