Strange crash on the server.

Hi everyone!

On server which I playing I found a strange bug. It look like a crash with error (check screen shot).

http://dshav.com/pub_pictures/strange_crash.png

After this crash I can’t connect to server. When I try to connect process was started but when my person must wake up server was crash again with same error message. I’ve check log and found this:


87958	145	96	768	Y	783629689617533662
87959	145	96	768	Y	783629689617533662
87960	145	91	728	Y	783629689617533662
---
2.0 / Error Dump Disconnected - Object reference not set to an instance of an object
  at UnityEngine.TransformEx.AddAllChildren (UnityEngine.Transform transform, System.Collections.Generic.List`1 list) [0x00000] in <filename unknown>:0 
  at UnityEngine.TransformEx.GetAllChildren (UnityEngine.Transform transform) [0x00000] in <filename unknown>:0 
  at Model.GetBones () [0x00000] in <filename unknown>:0 
  at Model.FindBone (System.String name) [0x00000] in <filename unknown>:0 
  at BaseEntity.FindBone (System.String strName) [0x00000] in <filename unknown>:0 
  at BaseEntity.UpdateBoneFollower () [0x00000] in <filename unknown>:0 
  at BaseEntity.StartParentFollowing () [0x00000] in <filename unknown>:0 
  at BaseEntity.UpdateParenting () [0x00000] in <filename unknown>:0 
  at BaseEntity.PostNetworkUpdate () [0x00000] in <filename unknown>:0 
  at BaseNetworkable.ClientInit (ProtoBuf.Entity info) [0x00000] in <filename unknown>:0 
  at BaseEntity.ClientInit (ProtoBuf.Entity info) [0x00000] in <filename unknown>:0 
  at BaseNetworkable.ClientSpawn (ProtoBuf.Entity info) [0x00000] in <filename unknown>:0 
  at Client.CreateOrUpdateEntity (ProtoBuf.Entity info, Single time) [0x00000] in <filename unknown>:0 
  at Client.OnEntities (Network.Message packet) [0x00000] in <filename unknown>:0 
  at Client.OnNetworkMessage (Network.Message packet) [0x00000] in <filename unknown>:0 
  at Network.Implementation.Raknet.Client.HandleMessage () [0x00000] in <filename unknown>:0 

Hardware:
Mac OS X 10.10.3 (Yosemite), Macbook Pro Retina Mid 2012, CPU: 2,3 GHz Intel Core i7, RAM: 8 GB 1600 MHz DDR3, Graphic: NVIDIA GeForce GT 650M 1024 MB

How it’s happened?
I’ve walking on the map and fond a few players who sleeping on the ground. I try to kill one from them and get this error (crash). When my friend try to loot me he also got this crash. I don’t know why. I try to reinstall game, reboot my Mac nothing help so I decide to way a few minutes. I not sure how many I was wait but after this problem was solved.

Many people on my server told me that they got that problem…

wow why they dont reply to this problem?

i can’t join with this error too in “facepunch hong kong”

i think this is coding bug

[editline]18th May 2015[/editline]

i keep to finding solution

but there is no anything

Try voting the thread up. Click on the green “Agree” check mark on the main post.

server low performance is reason??

thumb up

Thread ratings don’t change thread ordering here, this isn’t Reddit, although if you hit a certain number of ratings, it will show the rating next to the title in the threadlist. Rating agree simply means you agree with the post. That can be important information for a dev, of course.

And having said that, I’m not a mod so I can’t tell anyone what to do, but I’m going to strongly suggest to everyone not to make contentless bumps just to keep it on top. It’s just a bad idea.

This looks like a memory issue.

Try updating or reinstalling Directx to the latest version.

kk

i’ll try this when i’m come to home

if this is solution, you will be many players hero lol

Try also looking at you graphics driver.

Did it update around the same time as when the issue started.

If yes, then try rolling back to the older driver and turn off auto update on it.

IF No, Sorry

answer is no

i didnt update any drive at last update

but i’ll try update graphic driver to last version