Strange Derma errors.

I have this server I’m working on, and recently due to the gmod updates it kinda got … shaken up. Because of this alot of errors codes kept popping up, and we decided to make some new code. It all worked great in Create multiplayer and singleplayer, but as soon as we hosted it, it didn’t give any errors, but the loadout face got skipped.

Anyway, we reinstalled the server, and now I’ve just uploaded the exact same gamemode. The loadout works fine now, but suddenly we get these errors:



lua_temp\vgui\dpropertysheet.lua:154: attempt to index field 'animFade' (a nil value)
lua_temp\vgui\dhorizontalscroller.lua:72: attempt to index field 'btnRight' (a nil value)
lua_temp\derma\derma.lua:115: attempt to index upvalue 'derma_skin' (a nil value)


The third line pops up about 4 times and then the other 2 pop up.
I tried seeing if either the server has broken files, or my local files are broken, but joining other servers give no errors, and the files on the server seem to be the same as on other servers. (Several servers to compare with).

Another related bug: The scoreboard (basic sandbox one) just froze and got stuck on the screen.

Any suggestions?

This may sound like a stupid question and I’m probably wrong, but is derma installed on the server?

Yes the derma folder is indeed on the server. That is why I said I checked it with the other servers.
The folder is in there, and the files that are needed are in it.

Edit: Apparently it was PERP. And some guys fucked it up. Reinstalling it, and probally solved.

Requesting a lock/deletion?