Strange download problem with resource.AddFile

Hi,
I am using resource.AddFile to make a client download a few files using this script:


local resourceFiles = {
	"resource/fonts/OpenSans-Regular.ttf",
	"resource/fonts/Oswald-Regular.ttf",
	"materials/f4_logo.png",
	"materials/leftbar_texture.png",
	"materials/center_texture.png",
}
for _,res in pairs(resourceFiles) do
	print("Added resource file " .. res)
	resource.AddFile(res)
end

This of course, works! And the client downloads the files during the loading of the server!!
However, the client doesn’t “mount” or “install” these files. They still don’t exist on the client and they return missing textures and use the default fonts.
I made a small Workshop addon that downloaded the files and they worked.
How can I get this stuff to work? It’s really weird. It’s not just me, either.
Dragging the actual files to where they should be works, too.

Those files must exist on your server, as well as on your FastDL server.

Do I HAVE to have FastDL enabled for this to work? My server doesn’t use FastDL and this doesn’t seem to be working.

I have the files in the server’s files PLUS addons/theaddon/materials/ etc.

No, you don’t have to have FastDL. Do the files redownload every single time you enter the server? Does the content work if you install it into your game manually?

Yes. The content works when manually installed and the client redownloads the files on every join.

Post client console log. ( All of it )

You most likely have a FastDL server that is missing the files.

Do you also have sv_allowdownload set to 1?

-snip full console log-

[editline]30th August 2015[/editline]

Wow. This actually worked.
Thanks.
Who knew it’d be the simplest option. I’ve read places that the command doesn’t help.