Strange Gmod errors. Might be related to 360 controller.

I’m having some odd issues with my Gmod.
I cannot rotate any props, and all my bindings seem defaulted to gamepad commands. My crosshair is also strange, as it looks looks like a large circle with lines through it. I also sometimes spawn without weapons.

I tried De-fragging and checking the integrity of the Cache files, but they don’t do anything.

Also, this message is in the console; “Using joystick ‘Xbox360 controller’ configuration”. Is there any way i can reverse this?

I really need help with this, Because it’s really annoying. If anyone else had this error, tell me. Thanks guys.

Look,what you need to do is go in console and type…
Exec UNDO360controller
when you start gmod and have a gamepad it automatically binds that way.
if u undo you will have re-key everything yourself…
the one thing I can’t get by is the inability to rotate things.
I usually use my mouse or Xpadder.

I think typing “Joystick 0” has fixed it all anyway mate.
Thanks for your help anyway :smile: