Strange GMod Problems

For the past couple of weeks, as I start up GMod, it’s all fine. However, when I start downloading new content now, I have to access it through the “Browse” tab. So I try to go get it from there, and when I click the file where the ragdolls or props are at, there’s an error and there’s no spawn list. I also have another problem, which is with the “Toybox” tab. I can click on it, but when it loads, it comes up with either a -102 error or a -104 error. I have toybox enabled, so I have no idea what the problem is. I’ve tried just about everything, restart GMod, reboot my computer, verify it, do everything in the “Properties” in Steam for it, even reinstall it. Nothing worked. So I have no idea what the problem here is. It’d be great if anybody could help.

Toybox errors:

Error 104 (net::ERR_CONNECTION_FAILED)
Error 102 (net::ERR_CONNECTION_REFUSED)

these are networking errors. did you install some new software firewall?

I did not install a new firewall, no.

Do you have your ports configured for garrysmod? I don’t know if this will help but I think your firewall might be blocking some of the online services such as toybox in garrysmod.

Maybe it’s the new engine the valve has just released.