Strange graphical glitches

I’ve been having a strange problem with the skybox and water in the last couple maps ive been working on, and it hasnt happened in the past, its a problem that seem to have just cropped up with the latest two maps.

basically the water, whether its expensive or cheap is not rendering properly, it looks like the smearing map ‘leak’ effect

and the skybox will go black at seemingly random angles and directions

i KNOW there aren’t any actual leaks on the map, so that’s not the problem

ive tried countless tweaks, remaking the skybox, double checking to make sure all the walls meet, etc etc etc, but im just dumbfounded at this point

am i missing something? (again this isnt my first map or anything, i have never had this problem before)

Post the compile log. Also we have 2 question mega threads.

ah, yes forgot about the megathread (some question jsut seem to get lost and ignored in those btw…)

im assuming these errors are the problem

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (6144.0 2560.0 28.0)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

after googling, however, all im coming up with is that either there is a leak or the skybox is the wrong brush type, however there isnt anything different about how i made this skybox compared to any others that have worked in the past

Redo all brushes near “6144.0 2560.0 28.0”. These are coordinates, and think there’s a “jump to coordinate” button under the “View” tab in hammer

You know you don’t have a leak, but you do? How about fixing it first? Click map - load pointfile in the top bar, load the yourmap.lin file, follow the red line and seal the leak.

If the logs say you have a leak, you have a leak

the .lin file doesnt leave the area surrounded by the skybox, the red line is completely enclosed

If you get a lin file you have a leak. Are those brushes entities, displacements or water?

its literally completely within the skybox, i made a giant cube skybox (i know you should avoid that for efficiency’s sake) after i started having problems, just to make sure there would be no leaks; and it was made by make a cube and hollowing it out, so all the sides met properly of course

and those coords in the errors lead to points randomly outside the skybox

might be that there is an origin outside the skybox.

double checked, nope, the only thing outside the skybox surrounding the level is the smaller ‘actual’ skybox cube with the sky camera inside it

Paste everything in a new .vmf

no change unfortunately

And is the 3d skybox completely enclosed?

Don’t forget areaportals that don’t enclose an area also cause leaks.

yes, and yes, the current skybox is basically a strong-arm approach, it’s literally a giant cube that I use the “hollow” tool on and there aren’t any area portals on the map, it’s still in very early stages of being made.

I’m certainly not a pro mapper, but I’m not new either, I have double checked all of these things ten times over, and even remade the skybox several times, it just doesn’t make sense

    :suicide:

come to think of it, this only started happening after the recent patches that broke, then fixed Hammer, maybe that has some connection?

Don’t use hollow.

OK then, How do you suggest he does it? Because the Dev wiki suggests hollow.

there is nothing wrong using the hollow tool that way.

ok, so i put that map on hold and am working on an entirely different map for now, but a problem is still there

basically, the entire map is enclosed in glass, and then the skybox is on the outside of that glass

the bottom half of the sky isn’t being rendered however

screenshot:

this is skybox sky_day03_03, so there shouldn’t be a clean line dividing the sky from the ‘ground’ in the skybox texture, not to mention the ground is not even that color

pic from developer community:

BUT, as you can see in Hammer, the skybox fully covers the view behind the glass

screenshot:

once again, ive double checked everything and there just isn’t anything I can see that would be causing this

compile log: http://pastebin.com/n8a6in80

as you can see this time there isn’t even a leak error, but the graphics are still glitching