Strange problem on my DarkRP server

Hello everyone :slight_smile:

First post, First Problem…

So, some months ago i wanted to start my own DarkRP server. I started by downloading the server files and everything on my PC and build it whenever i had some free time. The server was working fine, no problems or anything, i even had some players on it.

3-4 Days ago, i bought a VPS so i can host my server 24/7 and then, all my problems started. I fixed most of them (i think, maybe more will pop-up after fixing this one?) and i managed to start it. I managed to see my server online but the VAC Protection shield icon isn’t there. I also see


[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Could not establish connection to Steam servers.  (Result = 18)
Could not establish connection to Steam servers.  (Result = 18)

at the bottom after everything loaded.

I am able to connect on the server but if someone else tries, he’s getting “Authenticating with Steam” instead of “Retrieving server info” at the loading screen.
If i quit, he will be able to join without problems but then i’m the one getting this error.

I googled it, i’ve been looking everywhere, nothing seems to help me.

I’m not familiar with Linux neither i know how to code, i know the basics only.

I tried to use -secure start-up parameter but still not able to see the VAC shield icon next to my server.

I’m running Ubuntu-14.04-x86_64

To create the server on the VPS, i followed the wiki

Any help would be appreciated!

Thank you!

Problem fixed

Solution: cfg files were not configurated correctly