Stuck on loading screen

So, I bought Rust yesterday and I have yet to play it until now. I load up the game and everything is fine, I join a server and it all loads until it eventually says “waiting for character” and I can’t get past that. Im on a mac and I can still hear the crickets and what not in the background but I have the rainbow spinning/loading ball and it will stay there. I have tried other servers and nothing seems to work.

http://puu.sh/5QiIV.png

It just says the program is not responding!
PLEASE HELP

Hello there!
Can you post your output_log for me to take a look at?

You can find where it would be located here:

Del

Same problem alot of people having it.
I have it in Dev mode still doesn’t work…
Model Name: iMac
Model Identifier: iMac12,1
Processor Name: Intel Core i5
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 4
Memory: 4 GB
OS: OS X Mavericks 10.9

Same except I have 8 gbs of ram

Are they gonna fix it?
Because this is Ridiculous being in alpha isn’t an excuse for a unplayable game

I am also having the exact same issue. Mid 2010 model, 4GB RAM, 2.4 GHz. I’m stuck on the “loading character” part of the loading screen.

it actually is exactly what ‘alpha’ means

Same exact problem here. 2011 iMac with 8gb of ram. Bought the game friday and have yet to play it.

my game seems to crash when i’m handling a weapon or getting anything in hand… Late 2013 27" iMac on Mavericks

I have this same problem! SOMEONE HELP US PLEASE.

TURN DOWN YOUR SETTINGS

They are down! I go on the Fastest graphics one (the shittiest one I guess) and I still cannot connect to any servers! I’m freaking out here man.

Ok, we understand that an alpha is unstable.
But the developers could just tell us that they know this bug and they’ll fix it when they’ll fix more important bugs.

Also, it could have cpp dev in the audience that can help them to fix it, if they explain why the keyboard id “bumping” (sound)

Paul, this thread is really, really old. Let it die.

adjusting the graphical settings via the unity box window does absolutely nothing… this is not a graphics problem this is a UI / probably the new HTML UI problem

Again, since people don’t like to read, this thread died back in December.

There was no HTML UI in December. Just let the thread die… again.

Sorry the UP, but is not better close the thread?

but you are just contributing to it even more , the text in witch it shows the date on the thread started at is ridiculously small - so how was i supposed to know that ? even when the thread was still on the 1st page/2nd page