Stuck on "Loading"

Hey guys,

Noticed a few other people have had similar issues when attempting to connect to a server, couldn’t spot a solution so just wanted to double check if there was/wasn’t one.
Basically I picked up the steam version a couple of days ago, installed and runs perfectly fine, however when I try to connect to any server I get a stuck at the loading screen.

The console shows this:

rust.
net.connect “server ip address:port”
connecting to “server ip address:port”
connecting to server

And thats all, it will just hang there indefinitely without throwing an error or actually connecting, however I am able to press escape twice then press the in-game ‘Exit’ button and try again. It Will connect to the server maybe 1 out of 10 tries.
Heres some additional info that other users asked for in similar threads:

  • CPU / GFX / RAM / OS
    i7 4770K, Gainward GTX 780 GLH (Latest nvidia drivers), 16GB DDR3 Gskill Ripjaws 2133mhz, Windows 8.1 Pro (All current updates).

What version are you running?
Latest version of Rust from Steam from an Intel 520 SSD.

Have you Verified your game Cache on Steam?
Verified the cache, deleted/re-downloaded/re-verified cache with no change in behavior.

Is your Internet Connection configured correctly?
Internet connection is configured as normally as possible (No overly strict outbound router port settings etc), tested with Windows firewall disabled and didn’t help.

Other things tested:
Tried all different graphic settings (Playing on fantastic by default and getting 120+ FPS)
Tried setting compatibility mode of the “rust.exe” to run as administrator
Tried using the net.connect “server ip address:port” in console instead of in-game menu to connect to servers

It is just an annoyance, when it eventually connects the game runs quite well and haven’t noticed any problems so far however any information on this particular problem would be greatly appreciated!

Cheers.

hey mate, i have the same issue and so do a few friends. you need to keep trying, it takes us roughly 5-10 tries of exiting the game and connecting before it actually loads! hope it gets fixed soon.

Its seems unlikely that this problem is due to any hardware or software on the client side. Those posting with similar problems have a wide variety of differeing hardware and OS’s… there are posts about this issue dating back to october. One thread suggests that a patch was issued to address this very problem back then. It seems to have fixed the issue with some users however there are just as many new posts about the same problem occurring afterwards. I have yet to see any official response to this. Of the 5 hours ive spent trying to understand this issue ive been able to log into only 2 servers and they were official servers. Was never able to log in to any community or modded servers. Ive tried all the run of the mill generic solutions with no success and no improvement. connecting to a server seems to be as random as it gets… I spent several hours last night attempting to connect to any server that wasnt full and never was able to connect at all… This afternoon i was able to log on the first attempt and played for roughly an hour and a half without incident. once i disconnected i was unable to log again… I get no error message just hangs on the connecting screen for 15-20 minutes and then says cant connect, nothing more. If i want to try another server it requires that i kill the game process and start again.

So until someone pulls their head out of the sand and recognizes this as an ongoing issue, were unlikely to see a solution. Its hard to rationalize that there are resources even devoted to this kind of customer support since this is an incomplete game anyhow. Since they already have the money i paid them to beta test their game for them, i cant see much incentive for them to expend any extra resources to solve the problems of a small number of customers. Its not like we can get a refund either…

…and for sake of completeness:

-windows 8.1 64-bit
-FX-8320 FX-Series 8-Core Black Edition
-8g G.SKILL Ripjaws DDR3 SDRAM 1600
-MB ASUS M5A97 R2.0
-all updates
-amd hd 5770 and XFX Core Edition Radeon HD 7870 (tried both, same results)

Im having the same exact problem, stuck on loading with no errors, have to back out of game fully before I can click on a new server, uninstall and reinstall dont seem to work to fix, playing through steam. Somebody help me out here, I understand its alpha but come on, how the heck am I suppose to help if I cant even get in the action.

CPU-FX6300
GPU-Radeon 7970
RAM-12 gb
OS-Win 8
Frustration level-MAX

What has seem to be working for me is to go to your local game files, and find the bundles folder, then select alphabetical sort, take everything from the manifest down and delete it, verify the integrity and it will download those files again and you can log on…once. Then on logout you have to do the whole process over. Im using steam btw.

screw that ^

i just copy my connect string (net.connect IPADRESS:PORT) and connect, alt/f4 and retry. usually after 5 - 10 tries i get in.

but yes this seems like its only happening to certain people.

(laptop)
7970m
i7 2630QM
16gb ram
750gb HDD + 128gb intel 520 ssd
Windows 8

+1 to everything above… waiting for a fix. League of legends does the same thing to me. Possible connection?

this is a long shot but, has anyone here disabled nagles algorithm? (a process that sends packets instantly, rather than bundling them up) - you can disable this by using leatric’s latency script. it helps with ping in other games. im wondering if we have all disabled this and maybe we cant connect properly cause of this?

I used to have similar trouble with LoL and resolved it by opening certain ports on my router, does anyone perhaps know of ports that need to be opened for Rust?

i have dozens of games that run on this particular machine that have no problems connecting… Breaking or enabling things because of a coding error or bad network implementation on the devs side is always a bad idea and generally just leads to the development of other problems that were non-existent before… Ping scripts and the like are generally only beneficial in very select instances and can commonly cause more problems than they fix. If other games work without issue and your internet works as usual then its easy to guess where the problem is… I encourage folks to be careful trying tricks to fix problems that are related to this piece of software (rust) as they might just lend to breaking things in other areas that were not broken before. So unless my isp is doing strange things with network protocols or filtering things specific to rust (and its network implementation) its clear to me that there are no problems with my router, my ram, my cpu, my internet connection, my dog , my cat or the sticker on the front of my case…! Its clear to me that the problem is rust and judging by the increasing number of new posts i see daily; is an on going issue.

a few things to try…

For users on windows 8.1 try adding -force-d3d11 to the command line options

Regarding ports, it’s usually in the range of 28000-28150

Also you can type net.disconnect in the console after failing to connect (bug) to use the browser once again

It would help to see your output_log.txt as well

I have the exact same problem too. Helk, I put my output log in this post if you want to see it. It seems like when I try to log into a Rust server, I just have to try to connect over and over again until it finally accepts my connection. It also appears that if I haven’t logged into Rust for an extended period of time, it accepts my first attempt to connect, but that may just be partly luck, because it doesn’t accept any others after that unless I try to connect ~30-50 times.
http://forum.facepunch.com/showthread.php?t=1333475&p=43171989#post43171989

Personally, I’m using Windows 7 x64 which I neglected to mention in that post.

That’s my output log. It takes me literally 20+ attempts to actually connect to a server.

I have the same issue, alt-f4 and trying to reconnect and around 15 connections later, I get in.

bump, looking for halp :frowning:

Same, my friend and I have been trying for so long now. We’ve tried 30+ time on 1 server, we’ve tried 1-3 times on each other server. Can’t even play the game yet :frowning: Hopefully this gets fixed soon, I have high hopes for this game :stuck_out_tongue:

Seems to be a problem that has cropped up today, in the past 5-8 hours or so. I was able to log in/off servers earlier today, but now, they all seem to have issues with hanging on the connection screen or getting the bounce/limbo errors…

Very frustrating, as I was trying to convince my two sons to pick up the game and try it, but this kind of issue makes it hard to get someone into the game.

Well, maybe, but it definitely hasn’t been just today for me and a lot of other people. It’s been going on for a while now.

i ran a packet sniffer to see what was going on, after it sends its larger packet (server connection request) it doesn’t get a reply, but it does keep pinging even whilst its hung on connecting…

Thanks for the tips guys, so far nothing has helped though.

Here are the contents of the output_log.txt.

Initialize engine version: 4.3.1f1 (cebd4d9b5122)
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 9.0c [nvumdshim.dll 9.18.13.3182]
Renderer: NVIDIA GeForce GTX 780
Vendor: NVIDIA
VRAM: 2963 MB (via DXGI)
Caps: Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=0 INTZ=1 RAWZ=0 NULL=1 RESZ=0 SlowINTZ=0
Begin MonoManager ReloadAssembly
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\UnityEngine.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-UnityScript.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Actor.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Actor.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Cursor.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Cursor.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Geometry.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Geometry.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.HitBox.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.HitBox.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.ID.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.ID.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.MeshBatch.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.MeshBatch.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Movement.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Movement.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Prefetch.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Prefetch.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Sky.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Sky.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Utility.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Facepunch.Utility.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\LitJSON.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\LitJSON.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Google.ProtocolBuffers.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Google.ProtocolBuffers.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Google.ProtocolBuffers.Serialization.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\Google.ProtocolBuffers.Serialization.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\uLink.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\uLink.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\dfScriptLite.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\dfScriptLite.dll into Unity Child Domain
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\EasyRoads3D.dll (this message is harmless)
Loading D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\EasyRoads3D.dll into Unity Child Domain

  • Completed reload, in 0.050 seconds
    desktop: 1920x1080 120Hz; virtual: 3600x1080 at -1680,0
    <RI> Initializing input.

<RI> Input initialized.

Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\System.dll (this message is harmless)
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\System.Core.dll (this message is harmless)
Missing Bundle bundles/navmesh.000.unity3d

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

You are trying to load data from a www stream which had the following error when downloading.
Could not resolve host: bundles; Host not found

(Filename: Line: 1066)

Shader ‘Diffuse’: fallback shader ‘VertexLit’ not found
Shader ‘Hidden/Sky Clouds Nominal’: fallback shader ‘Cumulus Perlin Layer SM2’ not found
Shader ‘Hidden/Sky Clouds Rain’: fallback shader ‘Rain Clouds Layer SM2’ not found
The referenced script on this Behaviour is missing!

(Filename: Line: 1699)

Instantiator for prefab ‘barrel_A1_01’ already exists

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Unloading 4 Unused Serialized files (Serialized files now loaded: 39 / Dirty serialized files: 0)

Unloading 34689 unused Assets to reduce memory usage. Loaded Objects now: 9365.
Total: 24.298170 ms (FindLiveObjects: 1.506439 ms CreateObjectMapping: 3.158285 ms MarkObjects: 2.287013 ms DeleteObjects: 17.021973 ms)

Steam Init

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Steam Finished!

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

GameUI Loaded

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

UnloadTime: 1.378001 ms
Unloading 0 Unused Serialized files (Serialized files now loaded: 39 / Dirty serialized files: 0)

Unloading 138 unused Assets to reduce memory usage. Loaded Objects now: 11318.
Total: 6.375376 ms (FindLiveObjects: 0.279111 ms CreateObjectMapping: 0.617906 ms MarkObjects: 4.363670 ms DeleteObjects: 0.346109 ms)

> net.connect 119.252.190.206:28135

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Connecting to 119.252.190.206:28135

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\System.Configuration.dll (this message is harmless)
Platform assembly: D:\Games\Steam\steamapps\common\rust\rust_Data\Managed\System.Xml.dll (this message is harmless)
Connecting to server…
(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Steam Shutdown

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)