Studio Compiler Help

I have been trying to work Studio Compiler, and tutorials have gotten me pretty far, but now I am trying to decompile the models from WW1 source and i keep getting this error.

Imgur

suggestions?

you need to open the mdl in a hex editor and change the fifth (fourth?) entry to 2c.

by hex editor do you mean like notepad? if not, then what? (provide link, pl0x)

Not like Notepad: http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm#download

ok, i have light_infantry.mdl open in the hex editor you gave me and all i see is a mess of numbers. which one do i change?

“IDST(number)” needs to be “IDST,”

k, i did that but i’m still getting the same error “unable to load model”.

Thats strange, out of interest what did it have after the IDST?

this:

Imgur

So it already had a commar, humm, seems the model is broken in some way then or the decompiler doesn’t like it.

actually, i put the comma there, but that still doesn’t explain why it doesn’t work…

I was asking what it had before you put the commar ¬.¬

sorry, i misunderstood.

it had a zero, so it was IDST0.

humm, thats OB format, that should work :S Have you tried using the older version (0.4.1) of the decompiler on it?

Decompiler page

Edit: Wait are you using StudioCompiler to try and decompile this? If so use the newest mdldecompiler on the page I linked there, StudioCompiler is a piece of crap (should really have realised that from the title ;^^)

same exact error. unable to load model.