Studio compiler problems

Hello,
I’m trying to compile a weapon model, but whenever I want to spawn it’s world model in GMOD, It’s invisible.

What’s wrong? How can I fix this?
Help would be appreciated.

Sounds like a texture problem. Most of the time when a model is invisible is because the VMT uses “lightmappedgeneric” for the shader which is wrong.

For models you need to use “Vertexlitgeneric”.

I tried again, you can see the “ERROR” model for a very brief moment, then it fades out.

If you get the model showing up as ERROR it means the model is not loaded or corrupted, or missing one of the parts [modelname.dx80.vtx, modelname.dx90.vtx, modelname.vvd, modelname.sw.vtx] Are you using the right path? if you specify a wrong model name in console you will get ERROR.

are you loading the model into garrysmod/models?

Or are you using addons/youraddonname/models?

Also does the spawnlist show an icon for your model, or an red ERROR icon for your model?

The model is in \Steam\steamapps\raging_blast\garrysmod\garrysmod\models\weapons,
It’s using the default pistol spawn icon.

I tried decompiling the compiled .mdl files to check if the .smd files are corrupted, but it looks normal in blender