StudioCompiler startup error

I followed all the necessary steps to make StudioCompiler work properly, however, when I attempt to start it up, it gives me the error message that says it can’t start because FreeImage.dll is missing.

I know I’m leaving out lots of information, but I don’t really know how to say it, just ask, and I’ll try and remember.

Any help will be much appreciated, thanks.

don’t use Studiocompiler, use studiomdl instead

I just tried it and when I use the one in the ep1/bin, it opens for half a second and closes, and when I use the orangebox/bin one, it comes up with an error message saying that it can’t start because vstdlib.dll is missing.

Why does my computer hate me so!?!

You have to run it from the commandline. Alternatively just drag and drop the QC file on top of it.

I’m quite new to modelling, so I don’t really understand what you mean by commandline or where I can get QC files from.

Could you please elaborate?

I’m sorry if I’m being too much of a burden, I know I could just look it up, but my searches so far have yielded no success.

Read that http://www.facepunch.com/threads/939746-Beginners-Guide-To-Modeling
I wrote it a year ago might help you.

Oh, yes, I was being an idiot, I remember what all this is now, so I gave it a try and…

Another error! Oh joy!

This time, the ep1/bin it still flashes on for only half a second, but it says that it has an error opening the .qc file, whereas the orangebox/bin one still has the vstdlib.dll error.

I would go as far as to say that it is Win 7 64-bit that is stopping me from using it, but judging by what has been said in other threads, I doubt this is the case.

Like I said, any help will be much appreciated.

Do start run cmd
then write “path to ep1 studiomdl.exe” “pathto qc file” let it run.
This way it won’t just flash.
Alternatively you can just write a batch file with



Path to studiomdl.exe %1
pause


And drag and drop the QC file on that.

To fix the dll error with the orangebox compiler I think you can copy paste the dll from the ep1 bin directory to the orangebox one.

Also quick thing before it shows up as an error again. Keep in mind that the compiler is not able to create folders. So if you have an mdl path which does not exist yet you have to first make the directories yourself.

Thanks, this really helped, however, is there any way of decompiling models with this?

http://www.chaosincarnate.net/cannonfodder/cftools.htm
mdldecompiler is the thing you need. You might have to hexedit the version of some headers though. Basically when you open an mdl file you will see a bunch of letters at the start IDSTx you need the replace the x(or whatever it is) to an , (a hex value of 2c)

Also you need to uncheck steam file access.

Thanks, I used this on my old computer, but I deleted it because I thought StudioCompiler was better (being an idiot, again).

EDIT:
Another error! Ok, this time, when I try to open it it comes up with an error that says ‘The procedure entry point Q_AppendSlash could not be located in the dynamic link libraray vstdlib.dll’. Please help.

MDLDecompiler needs to be placed in the %sourcesdk%\bin\ep1\bin directory (just type that in Run and it’ll take you to the appropriate directory :))

I already had it in that directory and still no success.

Do you have steam file access checked or unchecked?

It’s not a case of an error when attempting to decompile a model, it is however, a case of the program not even starting up.

Actually put it in %sourcesdk%\bin\ and see what happens then.

The same Q_Appendslash error occurs.

Would it require me to edit the .dll file?

Actually in what folder do you have the decompiler?

Folder path is important here
sourcesdk\bin\ep1\bin\mdldecompiler.exe

Works for instance

sourcesdk\bin\mdldecompiler.exe

Gives the appendslash error

The error comes up regardless of whether I have it in:

sourcesdk\bin\ep1\bin\mdldecompiler.exe
or
sourcesdk\bin\orangebox\bin\mdldecompiler.exe
or
sourcesdk\bin\mdldecompiler.exe

It registers that the necessary file is there, but it reports that there are factors withing said file that are missing.

Maybe the solution will require me to edit vstdlib.dll in some way, I’m not sure.

Any help is appreciated as always.