studiomdl error

http://content.screencast.com/users/antid2/folders/Jing/media/8af7fab4-8eb0-4bd6-b912-7ea82ef608e2/2010-05-11_0057.png

QC:




$modelname Folder\Dragon\Dragon.mdl
$cdmaterials models\Dragon
$scale 1

$body "Dragon" Dragon_Ref.smd



$sequence idle "Idle" FPS 30 activity ACT_idle 1
$sequence Test "Test" FPS 30 activity ACT_Test 1
$sequence Fly "Fly" FPS 30 activity ACT_Fly 1
$sequence Fire "Fire" FPS 15 activity ACT_Fire 1


$surfaceprop "flesh"



$collisionmodel "Dragon_phys.smd" { 
	$mass 20.0
	$concave
}




Do you have Steam on? :v:

Yep, and no games running, and i’m online.

I’ve never seen or heard of that error before. Strange. What are you compiling with? Just command prompt?

yep

I don’t want to mess with your compiling method or anything, but I might be able to help you better with something I’m more familiar with.

and if you have trouble getting it started
http://kathar.net/hl2modding/errors.php

well, this is my first model so no worries about my “method” xD

still outputs:
SteamStartup() failed: SteamStartup(0xf,0x0012F170) failed with error 1: failed to take master pipe connection lock

I heard of it before. You have to kill steam.exe process and start up steam again and try again. Usually works for me.

bump? :confused: nothing works

Did you obtain Source SDK legaly? Like did you buy a source game and dl SDK from tools?
Its not that im implying anything but ive seen this error before in illegal versions.

Restarting steam and all games (gmod, modelviewer, source sdk launcher etc) thru command prompt always works when I get this error

i’ve tried that. And yes, i own every valve game(legally)

When it happens to me, restarting steam or the SDK always fixes it.

Maw said it’s cause i use Windows 7, any speculation about that?

Try having the sdk model viewer open while you compile.

When i restart steam and do it, the first time it gives this error:


SteamStartup() failed: SteamStartup(0xf,0x0012F170) failed with error 1: Failed create pipe: 6, Win32 Error 6 "The handle is invalid."

ps:
it wont let me open model viewer either, says same error as before.

Delete your sourcesdk folder and let it re-download.

This usually fixes everything

[editline]11:57AM[/editline]

Only option left.