studiomdl.exe has stopped working ._.

**EDIT: **My problem is now solved! I’ll leave the original post’s text untouched below, here’s the solution:
I had to open up SFM, but instead of Launching the SFM, I launch the SDK, click on the dropdown at the bottom, and re-select ‘usermod’. This asks you to override a bunch of shit, hit OK, and then drag-n-drop the .qc over SFM’s studiomdl.bat, and beauty happens! Thanks for the solution to Ganon, over at SFMLab’s chatbox during it’s downtime. You are a hero.

Original post:

Yes, there were a couple other threads like this, yes I did read them all, no my problem wasn’t solved.

Hey there. I’m trying to learn how to port from XNALara to Source Filmmaker, with little success so far. I’ll try to provide as much information about my problem as I can.

The problem: When I hit Compile in GUIStudioMDL, it says studiomdl.exe has stopped working, and nothing happens.

The model I’m trying to compile is this: http://tombraider4ever.deviantart.com/art/AliceArmedClassic-and-AliceArmedPolkadots-release-288923642 (The first one, AliceArmedClassic)
I used Blender 2.71 and with Blender Source Tools 2.2.1, I can’t remember what I used to import the .ascii file (I had to tick some add-on in Blender, that’s for sure).

What I did the very first time:
Merge all its parts except the necklace and a blade, “remove doubles”, deleted all weapons, a few bones that were related to those weapons, scaled the model and the armature x35. I compiled the 3 files, and blender threw up the warning that they have 300+ bones, while SMD only supports 128 or so, but somewhere I read that this was not a problem.

I placed my .qc and materials in .png under E:\folder
This was the first .qc:


$cd "E:\folder"

$modelname "metssfm\Alice\Alice.mdl"
$model "Alice" "Alice.smd"

$bodygroup Necklace
{
	studio "Necklace.smd"
}

$bodygroup VorpalBlade
{
	Blank
	studio "VorpalBlade.smd"
}

$mostlyopaque

$cdmaterials "\models\metssfm\Alice"

$sequence idle "Alice" loop ACT_IDLE 1 fps 30.00

So, then I opened up GUIStudioMDL for the first time. I set the EP1 Tools Path to
E:\Steam\steamapps\common\SourceSDK\bin\ep1\bin
and the Orange Box Tools path to
E:\Steam\steamapps\common\SourceSDK\bin\orangebox\bin

After this, I switched the SDK Version to Orange Box, and clicked ‘Add’ and browsed in SFM’s gameinfo.txt. The Target Mod thingie became ‘Source Filmmaker [Beta]’. I left all the options on the bottom alone. I loaded up my .qc, with big sparking eyes I hit Compile, and bam. studiomdl.exe has stopped working. No error message in the console thingie. I tried again a couple times, tears in my eyes, it refused to work.

Alright, so the things I’ve tried since then, and made no difference at all:
-Decreasing polygon count in Blender below 10.000 with the Decimate modifier.
-Removed the bodygroups from the .qc.
-Removed first line from the .qc.
-Went back to Blender, reimported the original, exported without touching it at all.

Things that were sort of different:
-When I write gibberish into the .qc, it throws error as it’s supposed to.
-I tried drag-n-dropping my .qc onto studiomdl.bat in E:\Steam\steamapps\common\SourceFilmmaker\game\bin, which resulted in a simple file not found, hit enter to exit screen(I don’t know what file it’s talking about, the .bat only refers to the .exe next to it, and that’s there.), which is the strangest to me so far in this story. I created the folders
usermod\models\metssfm\Alice and usermod\materials\models\metssfm\Alice , maybe that’s the problem, but no difference.
-In GUIStudioMDL, I set the SDK to Episode 1, browsed SFM’s gameinfo.txt, and I got this:


Created command line: E:\Steam\steamapps\common\SourceSDK\bin\ep1\bin\studiomdl.exe -game E:\Steam\steamapps\common\SourceFilmmaker\game\usermod -notxbox E:\folder\Alice.qc

qdir:    "e:\folder\"
gamedir: "E:\Steam\steamapps\common\SourceFilmmaker\game\usermod\"
g_path:  "Alice"
Working on "Alice.qc"
SMD MODEL E:\folder/Alice.smd
SMD MODEL E:\folder/Necklace.smd
SMD MODEL E:\folder/VorpalBlade.smd

Then studiomdl.exe has stopped responding. The first line in this is as far as it normally gets.

Well then, I’d gladly hear some suggestions! This is my first time doing this, and I wrote down everything that I’ve tried, so if you’re thinking ‘nah, he’s surely tried this and that too, he’s not a complete retard’ then you’re wrong, and feel free to tell me what I could be missing. Thanks for any answers in advance.

Oh, btw, here, my SMD’s in case you want to try it for yourself:

Actually, that’d be great, if it works for you then I gotta reinstall smtin.

Your QC could use a bit of cleaning. Try this.


$modelname metssfm\Alice\Alice.mdl
$model Alice Alice.smd

$model Necklace Necklace.smd

$bodygroup VorpalBlade
{
	Blank
	studio VorpalBlade.smd
}

$mostlyopaque

$cdmaterials models/metssfm/Alice/

$sequence idle Alice.smd loop ACT_IDLE 1 FPS 30

It’s not completely necessary to follow this convention, but I’d recommend it. Make sure all your paths are set up correctly too.

Also, you may want to try compiling a simple box model or something first. The insane amount of bones/vertices is most likely the deciding factor.

That’s actually a good idea.

Did File -> New in Blender, deleted the Camera and the Light so I had the box left, made Cube.smd, and this .qc:


$modelname "metssfm\Cube\Cube.mdl"
$model "Cube" "Cube.smd"

$mostlyopaque

$cdmaterials "\models\metssfm\Cube"

$sequence idle "Cube" loop ACT_IDLE 1 fps 30.00

FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF…
Same problem, studiomdl.exe has stopped working, as soon as I click Compile, no error message, just this line
Created command line: E:\Steam\steamapps\common\SourceSDK\bin\orangebox\bin\studiomdl.exe -game E:\Steam\steamapps\common\SourceFilmmaker\game\usermod -nop4 -nox360 E:\folder\box\Cube.qc

Edit: By all paths being set up correctly you just mean the 2 paths in GUIStudioMDL right? And those don’t include the steam username, so they’re the same for everyone, right? Or did I miss something there?

Then it’s a problem with the studiomdl itself.

Try the SFM compiler.


...\Steam\steamapps\common\SourceFilmmaker\game\bin\studiomdl.exe

double clicking or drag-n-dropping onto the .exe results in a quick flash of a window that instantly disappears.
double clicking or drag-n-dropping onto the .bat results in what I’ve already wrote, “the system can’t find the path” (my Windows is not in english, so this is just rough translation, but yeah, it can’t find some file, which is extremely strange to me, considering the .bat is 4 lines, only refers to the .exe, and the exe is right there next to it.)

Edit: whoa, if I double-click sourceSDK’s studiomdl.exe it throws up that I have a missing parsifal.dll, that I googled, and apparently I need to refresh some SDK content thingie, let’s see if that works :open_mouth:
Edit2: If only I knew how to do such a thing. Btw I don’t have normal SourceSDK installed, just the one that came with SFM, but afaik they are the same.

UGGGGGGHHHHHHHHH. Use the STUDIOMDL.EXE provided with HL2, its probably the most stable, excluding the L4D and L4D2 ones.

I dislike the fact everyone calls GUIStudioMDL an issue when it isn’t, but that’s besides the point.

[editline]2nd November 2014[/editline]

I don’t think SourceSDK has worked since like 2012/2013

[editline]2nd November 2014[/editline]

I’m pretty sure the only thing that works in it is TF2 hammer, and maybe CSS hammer configs.

[editline]2nd November 2014[/editline]

It’s not even that fucking hard to get SDK to work again, Valve is just too lazy to do anything

Aight, so now I have a Cube.smd and Cube.qc that looks simply like this:


$modelname metssfm\Cube\Cube.mdl
$model Cube Cube.smd

$mostlyopaque

$cdmaterials models\metssfm\Cube

$sequence idle Cube loop ACT_IDLE 1 fps 30.00

Now, about HL2 studiomdl, I have it under common\Half-Life 2\bin. But what do I do with it?
I tried giving GUIStudioMDL HL2’s gameinfo.txt and try to compile, result is “studiomdl.exe has stopped working”.
I tried dragdropping the .qc over the .exe, a window flashes up and insta-quits. Both cases the same as with SourceSDK’s studiomdl. :’( What could be wrong…? I downloaded HL2 right now, so that can’t be missing files. I “verified the game chache” of SFM, it had like 50 files missing, then I tried again with SFM’s studiomdl, but made no difference.

If we assume something needs reinstalling, what could that be? Like I said, HL2 got installed just now, so how come even Its studiomdl.exe crashes instantly? Are there even any circumstances when it’s supposed to crash? It should just give an error, but not crash, am I right? Losing ambition here q_q

Edit: Could it be Blender’s exporter?
Edit2: Am I using studiomdl.exe correctly at all to begin with? Or am I supposed to use it from a command promt? if so, how?? I checked the wiki, but I don’t understand. It said it required a path parameter, so I gave it the .qc’s path, then it said it’s missing a game parameter, so I gave it a gameinfo.txt parameter called ‘game’, then it stuck the two path strings together and tried to do something with that for some reason(which looked something like E:\folder1\folder2\E:\folderX\folderY, good luck finding that directory ._.). Halp.

I can’t argue with that but from the looks of it they’re abandoning a lot of Source related stuff now and probably preparing for Source 2 stuff (despite that leaving us all in the dust until Source 2 is actually released and usable).

I personally use the Source SDK Base 2013 files (replaced them with the Source SDK files). It’s the newest Orangebox compiler that works and SFM’s compiler results in certain issues with GMod (primarily because I work so closely to the bone limit).

I dun fixed the damn thing, the thread may now be closed :wink: Thanks for all who tried to help! I put the solution at the top of the first post.