Stutter/Flickering in either Single/Multiplayer (video included)

I have encountered a weird issue ever since getting a monitor that has a higher frequency (dual monitor setup), if my game is in windowed mode then my game will start stuttering vigorously. The only solution is to either go full-screen which is very inconvenient for coding, or stay windowed and see the camera/view-model flicker up and down. It happens to me in single & in multiplayer. If there is anyone who could help me troubleshoot it would be gladly appreciated. I’ve taken the liberty to make a video with the actual game-play and then a monitor recording. As there are dropped frames in the game-play recording from NVenc which could be why you can’t see the stutter in the game-play recording. The game itself is smooth as ever full-screen but when I go windowed I stumble across the following:

  • A slight stutter on movement or every so often when idling (this gradually gets worse the longer you stay in windowed)
  • Single or Multiplayer, it does not matter the stuttering occurs
  • Stuttering persists to menus as well as the steam-overlay

I’ve tried:
Re-installing the Game
Verifying Game Cache
Searching Facepunch for a solution
Turning all addons / workshop items off

My only solution is to go full-screen, which is very inconvenient for development. I would like to urge for a possible solution towards this problem. I can consistently reproduce this on demand when I go in-to windowed mode on any game-server with or without addons. enabled.


Thank you!

Have you tried without the second monitor connected to see if it fixes the problem?

Have you tried moving the game to the second monitor to see if anything changes?

Have you tried lowering the refresh rate of the second monitor to see if anything changes?

What are the screen resolutions of both monitors?

What graphics processor the game runs on? ( Integrated Intel one or Dedicated one? )

Which graphics processors each of the 2 monitors are connected to?

  1. Unplugging my second monitor (1080p, low refresh rate) unlocks my frame-rate as well as fixing the issue for my 1440p at 165 hz.

  2. Moving the game to the monitor with the lower refresh rate also lets the game run unlocked with no stuttering

  3. Lowering my refresh rate keeps my FPS capped at 60, as well as stuttering occurring

  4. 1440p 165 Hz with G-Sync, 1080p 60 Hz

  5. I am using two GTX 1080’s in SLI, (turning SLI off or on changes nothing and the same things happen on both monitors)

  6. They are both connected to my main GPU.

Does it happen in other games? Other games on Source 1 Engine, like TF2, CS:GO/whatever/

It does not happen in the games which I tested as of your post (TF2, CS:Go, CS:S). In those games I have a unlocked frame-rate and no stuttering when in multiplayer or single-player.

Can Gsync be disabled? Does disabling it change anything?
Are you forcing the GMod’s mcore mode on?
Do you overclock anything? If you do, try disabling it.
Try physically removing one the GPUs and see if that does anything.

It is entirely possible that GMod just can’t handle GSync properly.
I don’t have nearly as good of a setup as you so I cannot test this.

You’re right, G-Sync is the culprit.

  • Turning G-Sync off for Windowed seems to unlock the game’s frame-rate.
  • Turning G-Sync to full screen only seems to fix the issue as-well.
  • Turning G-Sync back on in windowed and setting the monitor to ULMB (Ultra Low Motion Blur) mode on unlocks the frame-rate

You can adjust G-Sync in the Nvidia Control panel per-3D application with the options being ULMB, G-Sync or the Fixed Refresh Rate.

**Edit: **
I did also try turning mcore off and that didn’t do anything either. It was definitely G-Sync.