Subscribed workshop addons not installing

I recently installed Garry’s Mod and Steam on a separate SSD in my computer (alongside already having it on my main hard drive) and it didn’t load any of the workshop addons I had downloaded. I found this strange because every time I had previously installed Garry’s Mod somewhere, it had downloaded all of the workshop addons. I restarted my computer and booted into the main hard drive to see if my addons were working on the original install of Garry’s Mod, and when I opened the game they weren’t in my subscribed addons list, yet the GMA files were still in my addons folder. It also says that I’m still subscribed to the addons in the Steam Workshop. I’ve tried deleting Garry’s Mod on the SSD, which didn’t seem to work so I backed up my screenshots/advanced duplicator files/legacy addons and reinstalled Garry’s Mod on my main hard drive, and it still didn’t install the addons I had subscribed to. It’s not installing subscribed addons now, either. Anyone know how to help?

http://puu.sh/hwZYA/d1766d6dc9.jpg

http://puu.sh/hx05S/8ad154a969.png

Does it work if you reinstall GMod onto your main hard drive? (The one where windows or Steam are)

This is a common problem and nobody knows what’s causing it.

Some say changing time ( to the actual/correct time ) in your BIOS fixes this.

Thanks, that actually worked!