Sudden Hammer crash on vmf load

Yesterday, I was making a TF2 map, all went well. Saved it, turned off pc, and went to bed.

The next day (today) I wanted to map further on that map. I click the file I wanted to load, only to crash to desktop at 33%, without any warning. Just a sudden crash.
Then I restarted Hammer, to get the message that “The map wasn’t saved properly, do you want to go back to your last auto-save?” (or something like that). I clicked yes, but it still crashed, but this time with the message:

I click on ok, only for Hammer to “Stop responding”.

After restarting Hammer again, I still get this error, or just a sudden crash to desktop when I opened the map manually.

**I’ve tried:

  • Looking the error up (didn’t bring up any info)
  • Verifying case of SDK (didn’t work)
  • Switching to another game that’s not TF2 engine based, and opening it there (didn’t work, .vmf problem? The rest of the maps open just fine.)**
    - Restarting Steam

Please help!

I had a similar case, not the same error though. I restarted my computer and that fixed it. Try doing that if nothing else works.

I fear the worst. Your .vmf may be corrupted.

Well restarting my pc didn’t work. I might decompile my last .bsp file, to get to the .vmf.

Try going to the folder where the .vmf is and renaming the .vmx to .vmf, and loading it.

Didn’t work. It just crashed to desktop. The latest bsp (or the vmf we’re having trouble with) loads fine in TF2.

Also, I had been fiddling with mat_speculars and mat_reloadalltextures, to get cubemaps compiled in tf2. Could that be a problem?

doesn’t hammer have like 5 autosaves named mapname_1 to mapname_5 someplace
try them

You’re right, I forgot about those. I’ll try them right now.

It didn’t work out; I had another map named after that, and apparently, it didn’t save over it :saddowns: