Suddenly... Emitters stop working?

So I noticed that my emitter tool has suddenly stopped working. This seemed to have happened after I downloaded the Collision Resizer Tool from Workshop. I have since uninstalled and removed it completely, but I am still getting LUA errors from my emitter tool now.

Can I get some help?

Here is the error I’m getting right now…



[ERROR] gamemodes/sandbox/entities/weapons/gmod_tool/stools/emitter.lua:113: attempt to call method 'SetScale' (a nil value)
  1. MakeEmitter - gamemodes/sandbox/entities/weapons/gmod_tool/stools/emitter.lua:113
   2. LeftClick - gamemodes/sandbox/entities/weapons/gmod_tool/stools/emitter.lua:69
    3. unknown - gamemodes/sandbox/entities/weapons/gmod_tool/shared.lua:251


You replaced default files. Delete your Sandbox gamemode then verify GMod.

Thanks a lot. :slight_smile:

It seems like its still not working… I still get errors when using emitters… any ideas? I tried to verify the cache, but GMOD said that 186 files could not be verified or something along those lines…

I’m going to try removing the custom emitters, then sandbox, then reverifying GMOD.