Sv_downloadurl broke Darkrp

Every time I join my server i get the following error that breaks the whole game. It happened
now that I’m using sv_downloadurl.



Couldn't include file 'darkrp\gamemode\cl_init.lua' (File not found)
**********************************************
**********************************************
********** COULDN'T LOAD GAMEMODE!! **********
**********************************************
**********************************************

There was a problem opening the gamemode file 'darkrp/gamemode/cl_init.lua'


I tried deleting the files in the server cache folder, re-running it to pack them again and copying the new cache to the web space but to no avail.

Am I not packing the gamemode properly?
Since all darkrp is, is lua files (other than earthquake.mp3) I’m assuming that the cache folder takes care of that (since I read not to upload the lua files to the web space because they are in the dua file in the cache folder).

did you upload the server’s cache folder to the FastDL location

Sorry if I didn’t make it clear but yes I did

It couldn’t hurt to upload your gamemode’s lua files. Worth a try anyway.

I guess :biggrin:

I run a server with manual FastDL and I got the “base gamemode” problem. I literally took every single thing in garrysmod and uploaded it to FastDL. It fixed it.

or, Disable the fastDL. That will fix it

Yup, that should fix it. I recently had loads of problems which went away like that ^^

Thank you both (yes the “base gamemode” problem is my problem as holding TAB says so, which tells me you two had the same exact problem) I will try that latter today (as it is 3 in the morning) as it sounds like an excellent idea and that it will definitely work.

I would turn it off but that would defeat the purpose.

That is the dumbest thing i’ve ever heard…

All you need to upload is your custom materials/models/sounds and your cache folder. Make sure you update your cache folder every time you update one of your addons such as Wiremod or PHX or else they will never download it and it will act like it did everytime they connect.
Manually go to that link of your fastdl and make sure the permissions are correct and clients can access the files without any 404 or 403 problems.

Ok, that is helpful too. I forgot to check the permissions and I didn’t know that even if it didn’t work it would act like they downloaded it.

And do they really have to have write access?

[editline]03:03PM[/editline]

EDIT: I checked the permissions and read and write were there but when I tried to go to the url in firefox, some error came up from the place that hosts the site so I shall try another place.

I know I didn’t NEED everything, (and actually I took out PHX/Wire and such).

I just decided it would be easier to go overkill on it than miss something.

Well, If you install your addons properly, then you wont need to “miss” anything.

All you need is your custom materials models and sounds with the cache folder nothing more nothing less.

ALSO: They download the lua files, not the materials unless its scripted inside the lua.