sv_downloadurl not sending lua cache file

Hey, When somebody downloads from our sv_downloadurl , They download the models and such maps etc. The Lua Cache file lists in the downloads but seems like a almost instantaneous download. Then when they join the server it says Lua cache could not be downloaded, Server is misconfigured. Ive copied over the updated cache file which the server generates to the sv_downloadurl.Whats going on?

[editline]12:15AM[/editline]

Note: Turning off fast download fixes the problem. But FastDL is a must!

Recheck the URL, are other models being downloaded?

Yes. Everything but the lua cache file.

After map change you need to upload Lua cache file to Fast Dl

Dude, You dident read the thread but anyways I fixed it myself by simply reinstalling the fastdl.

Reinstalling fastdl? There’s no such thing

Don’t you mean your folders were wrong and you just realized the stupid mistake.

what is fastdl i have that problem to how do i fix it

If you dont know what it is then you wont have a problem with it seeming that you have to enable it.

Hmm, Okay its not working again. Ive done it the right way. Not working, Ive tried all your suggestions not working. Ive recopied the lua cache over hundreds of times not working. Ive deleted my Fastdl directory and re-copied them over again and did all the usual, not working. everything else, even the maps download perfectly. The lua cache is being a bitch and not downloading. How do I fix this, Note: Im running DarkRP.

[editline]02:30AM[/editline]

No, Folders are all correct. And by reinstall I mean delete my fastdl directory, and start the process all over again.

I am having the same problem, I can’t even get the cache to send without fastdl…

Are you using the Linux binaries aswell?

I had the same problem (if your using the lin-bins that is) Your cache folder is created with different access properties than the other folder for some reason.


sudo chmod -R 0777 cache/

You could be a life saver. Lets find out.

[editline]06:09PM[/editline]

Bah doesent work. Darn.

How is your server setup? Is the httpd on the same pc as the server?

All I did was create symlinks from the ~/srcds_l/garrysmod/* to the /var/www/gmod/* and chmod’d the ~/srcds_l/garrysmod/* directories.

if you run tailf on the /var/log/apache2/access.log does it show the clients trying to download the files?

Edit:

Also the wiki says to setup your sv_downloadurl with a / at the end but when you do that the clients request for /gmod//cache/blah.dua

So make sure your svn_downloadurl is http://example.com/gmod without the trailing forward slash.

(same server as OP)
There is apache2 on the server aswell, in the logs it has this:
96.50.xxx.xxx - - [01/Aug/2010:09:29:08 +0000] “GET /fastdl//cache/726364557dc12b9ec10c473057e602 4b.dua.bz2 HTTP/1.1” 404 399 “hl2://212.117.167.184:27015” “Half-Life 2”
96.50.xxx.xxx - - [01/Aug/2010:09:29:09 +0000] “GET /fastdl//cache/726364557dc12b9ec10c473057e602 4b.dua HTTP/1.1” 404 395 “hl2://212.117.167.184:27015” “Half-Life 2”
96.50.xxx.xxx - - [01/Aug/2010:09:32:13 +0000] “GET /fastdl//cache/726364557dc12b9ec10c473057e602 4b.dua.bz2 HTTP/1.1” 404 399 “hl2://212.117.167.184:27015” “Half-Life 2”
96.50.xxx.xxx - - [01/Aug/2010:09:32:13 +0000] “GET /fastdl//cache/726364557dc12b9ec10c473057e602 4b.dua HTTP/1.1” 404 395 “hl2://212.117.167.184:27015” “Half-Life 2”

Exactly :stuck_out_tongue:

take the / off the end of the sv_downloadurl and it should work.

ffffffuuuuuu
I just noticed the folder in /home/gmod wasnt mount --binded to /var/www/fastdl

and there was a extra / in the config files

I think it works now :smiley:

I have no idea what is wrong with mine, I updated it and now it won’t send anything.

Updated the gmod or http server?

GMod server