sv_loadingurl not working

Hi i just got a new html Background for gmod and it works fine on my friend server but when i try o use it it doesnt work

any help?

the sevrer.cfg is as follows

// server name
hostname “TA1P [1] Roleplay [WIRE|PCMOD2]”
sv_loadingurl “************” (blanked so no one can steal the code)
sv_allowdownload 1

// rcon passsword
rcon_password ************

// Server password
sv_password “”

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 33
sv_minupdaterate 10

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0
net_maxfilesize 64
sv_alltalk 0
mp_timelimit 0
mp_flashlight 0
sbox_noclip 0
sbox_plpldamage 0
sbox_maxeffects 0
sbox_maxthrusters 0
sbox_maxemitters 0
sbox_maxturrets 0
sbox_maxprops 50
sbox_maxhoverballs 0
sbox_maxvehicles 0
sbox_maxlamps 0
sbox_maxwheels 0
sbox_maxragdolls 0
sbox_maxbuttons 3
sbox_maxballoons 0
sbox_maxdynamite 0
sbox_maxspawners 0
sbox_godmode 0

thanks

We can’t help if we can’t see the loading page. hurr.

Have you tried reloading the map after starting the server? If not I have a really simple script that does it automatically.

[lua]hook.Add( “Think”, “I_hate_flatgrass”, function()
if game.GetMap() == “gm_flatgrass” then
game.ConsoleCommand("changelevel gm_construct
")
end
end
)[/lua]
(Save it in the servers lua/autorun directory, doesn’t matter what name it has)

Simply set your servers default map to gm_flatgrass (or a map you dont use, be sure to change the code to correspond to it) and where it says gm_construct change that to the default map you actually want.

Thanks ill give them a try and im not displaying the Url becuase yoiu can copy the code. i definitly works, my friend tryed it on his server.

For loading url to reload, the server.cfg file has to be reloaded and the map changed, or the server has to be restarted. If the server is restarted, what’s the point of your script… ?

I have restarted the sevrer etc but its not working lol for some reason the server wont display it

Add the sv_loadingurl “http://yoursite.com” into your autoexec.cfg

If you don’t have an autoexec.cfg just make one and save it in your cfg folder (where the server.cfg is located).

Ill give it a go Thanks

[editline]5th February 2011[/editline]

Did not work :confused: i tried making a new file autoexec.cfg (i copied serve.cfg but changed name and the stuff inide it) and then added sv_loadingurl "MY LINK IN HERE) and it did not work
:confused:

I had this problem too when I owned a server, if your link starts by http://, then remove it. So your link would look like www.<link>.com

Ill give it a go thank you

[editline]5th February 2011[/editline]

I just tried it and it didnt work. i am using the same sevrer.cfg as my friends but diffrent servers and hosts and it worked for him :confused: thanks anyway

Don’t move all the cvars from your server.cfg into your autoexec. (don’t copy the server.cfg and change the name)

Try adding only the sv_loadingurl “http://yoursite.com/” into the autoexec

I did :/. i justy made the new file (i copied server.cfg then rmeoved evrything in it and renamed it) then i put

sv_loadingurl " —MY LINK—"

Just give your damn link. I think you have something done wrong with the page.

Go to your server console. Type: sv_loadingurl loadingurl.com/garrysmod/loading.php (or whatever the url is.) Then type map gm_construct (or whatever map you want.) Then join your server.

PM me the link and i’ll see if theres anything wrong. if that fails. Try booting the server using +sv_loadingurl URLHEREWITHNOQUOTES
just drop a support ticket to your hoster if it doesn’t work, but first send me the loadingurl incase theres anything wrong

And if I wanted to steal it i’d simply join your server and type sv_loadingurl and it’d tell me it

Looking at the link under your avatar to a site made with Wix may be the problem, if of course the loading url is made with wix

Where is Autoexec.cfg im lost


(User was banned for this post ("Dumb bump" - Ninja101))

I think this feature is broken in the latest version of Garry’s Mod mine & hundreds of other servers just display a plain white background.

Yeah, except this thread was created over a year ago (ie. before the HTML panels broke).