SWEP Animation glitch..

Whenever I use a swep, my player holds it like it’s a pistol. This is really annoying when I’m trying to make a machinima, because the hand tools do the same! Can anyone help?!

ok, well try checking if it is actually the swep that is wrong. go into the
lua/weapon/weapon_whatever/shared.lua file and press ctrl+f then type in ‘holdtype’ then see if it says pistol, or another weapon.

Ok, I’ll try that, thanks

Newest update made it.

Bugs everywhere!

Fucking bugs…

I know how to fix this. I fixed it in all the weapon packs I used. Please reply with the weapon pack you are using.

did u go into the file?

I’m using The Madcow’s Weapon pack…

http://www.mediafire.com/?xjq4l2uznnz
Heres a fix for Madcows, All credits go to JIAC, for replacing all the files for madcows.
Direction: It’s basically just a re-upload of the entire pack, so remove your old one and just add this one in its place.

I’m using Cheesylard’s Machinima Hands swep.

Edit: Nevermind, I found a replacement. Still, is there a general guideline for fixing the problem?

Thanks! This worked!