SWEP crosshairs

i want to modify a swep pack for the first time to see what the lua can do. So how would you remove those ugly green crosshairs on some weapons (ex. tactical weapons pack)? Which command line?

post the code please. i wont be installing that mod just to help you.

how is this bad spelling? every word was spelt right

no im making mine own
ok ill post it

[editline]11:37AM[/editline]

SWEP.PrintName = “NOMgun”
SWEP.Slot = 1
SWEP.SlotPos = 4
SWEP.DrawAmmo = true
SWEP.Category = “Poopguns”;SWEP.DrawCrosshair = true
SWEP.ViewModelFlip = false
SWEP.ViewModelFOV = 70
SWEP.ViewModel = “models/weapons/v_crapgun.mdl”
SWEP.WorldModel = “models/weapons/w_crapgun.mdl”
SWEP.ReloadSound = “weapons/pistol/reloadsound1.wav”
SWEP.HoldType = “ar2”

SWEP.Weight = 10
SWEP.AutoSwitchTo = false
SWEP.AutoSwitchFrom = false
SWEP.Spawnable = true
SWEP.AdminSpawnable = true

SWEP.Author = “FLUBADOOFTW”
SWEP.Contact = “nonono@yahoo.com
SWEP.Purpose = “first thing so it sucks”
SWEP.Instructions = “press! right click for the worst iron sights eva”

SWEP.Primary.Sound = “weapons/crapgun/fire.wav”
SWEP.Primary.Damage = 35
SWEP.Primary.NumShots = 1
SWEP.Primary.Recoil = 1
SWEP.Primary.Cone = 0.06
SWEP.Primary.Delay = 0.3
SWEP.Primary.ClipSize = 50
SWEP.Primary.DefaultClip = 750
SWEP.Primary.Tracer = 2
SWEP.Primary.Force = 5
SWEP.Primary.TakeAmmoPerBullet = false
SWEP.Primary.Automatic = false
SWEP.Primary.Ammo = “SMG1”

SWEP.Secondary.Sound = “”
SWEP.Secondary.Damage = 0
SWEP.Secondary.NumShots = 0
SWEP.Secondary.Recoil = 0
SWEP.Secondary.Cone = 0
SWEP.Secondary.Delay = 0
SWEP.Secondary.ClipSize = 0
SWEP.Secondary.DefaultClip = 0
SWEP.Secondary.Tracer = 0
SWEP.Secondary.Force = 0
SWEP.Secondary.TakeAmmoPerBullet = false
SWEP.Secondary.Automatic = false
SWEP.Secondary.Ammo = “none”

SWEP.IronSightsPos = Vector ( 3.4753, -2.2385, 2.19845 )
SWEP.IronSightsAng = Vector ( 2.1, -2.0023, 0.0024 )

What if you changed
SWEP.DrawCrosshair = true
to
SWEP.DrawCrosshair = false
?

How would that work?

yes that would work. but then if you wanted a crosshair you would have to change it back to true and edit the other code

oh ok

[editline]04:46PM[/editline]

ugh. It still is there. It might be with the base or something. I don’t know, but the crosshairs are flat out HUGE.

I tought so too, but the code you posted doesn’t use a base.

try making SWEP.Primary.Cone = 0.06 a lower number. this might not work but you could try