Teams aren't showing up in the default built-in team menu


--shared.lua in my gamemode

GM.TeamBased = true

--TEAM_TERROR = 1
--TEAM_COUNTERTERROR = 2 I tried these and they didn't work so I tried the numbers seen below. still doesn't work

function GM:CreateTeams()
team.SetUp( 1, "Terrorists", Color( 255, 0, 0 ) )
team.SetUp( 2, "Counter Terrorists", Color( 61, 87, 105 ) )
end


This results in:

http://postimg.org/image/oipgisfyn/

even though I have these two teams defined. What am I doing wrong?

The problem doesn’t lie in your shared file.

Paste the dermamenu you created.

Sorry to ask but how familiar are you with dermamenus? You should know that that button could be “shitface” and still send you to any team…

I didn’t make the derma menu. It’s built into gmod. But, if you’re wondering, I’m very familiar with derma

Are you sure your shared.lua file is being included by cl_init.lua?

Oh, I need to include shared.lua in cl_init.lua? Thanks, that’s probably the problem. I might make my own team menu in the end, though, my theme of using transparent dark derma menus won’t be followed with the default grey one triggered by GM.TeamBased, heh