Terrible Rust lag! HAILP!

I’ve been getting alot of rust lag lately I’ve tried the “grass.on false” and putting the render settings to nothing, setting the resolution to my monitor resolution. All of that I tried but nothing works still getting like 9-13 frames. I know the game is still in alpha but this lag is really annoying. Any other suggestions?