Texture becoming invisible on my object

Well I tried some modeling and I ripped a model from gta 4 and after some time I got it in the model viewer but the texture is just transparent even though there isn’t a single transparent pixel on the entire texture.

.vmt



"LightmappedGeneric"
{
	"$basetexture" "carlton/cctv"
}


The vtf is placed in materials/carlton under the name cctv.vtf

.qc



$modelname		carlton\cctv.mdl
$body mybody	CCTV.smd
$staticprop
$surfaceprop	"metal"
$cdmaterials	carlton
$scale			1

$sequence idle	"idle.smd" loop fps 1

$collisionmodel	"CCTV-phy.smd" { 
	$Mass 50
	$concave
}

$keyvalues
{
   "prop_data"
   {
       "base"  "Metal.Medium"
   }
}

I get no errors in model viewer and I have no idea what is wrong.

And an image of how it looks

http://filesmelt.com/dl/cctv.png

(I have both textured and wireframe on so you can see that there actaully is something there

Help please :slight_smile:

lightmappegeneric to vertexlitgeneric

Thanks mate that worked wonders :smiley:

Oh and can someone please inform me if there is a better program the zmodeler to convert the models to .3ds? mine only converts modelfrags (.wft)

[editline]lol[/editline]

When i changed the texture everything became green. wtf?

[editline]lol2[/editline]

It fixed itself somehow lol