Texture help!

Ok, I’ve got an animated texture, so how can I save each frame into a separate file? when I try to go to the next frame and save it, it only stays on the first frame when I open it, if that makes sense. (I want to generate normal maps for each frame.)

And, the animated caustics texture I am using comes up with purple and black squares, yet it has a vtf and vmt inside the textures folder of my mod, why is it doing that? If it helps, here is the code. (To make it clear, no I did not make this.)

“LightMappedGeneric”
{
“$baseTexture” “liquids/water_reflections”
“$translucent” “1”
“$additive” “1”
“Proxies”
{
“AnimatedTexture”
{
“animatedTextureVar” “$basetexture”
“animatedTextureFrameNumVar” “$frame”
“animatedTextureFrameRate” “24”
}
}
}

[editline]18th May 2011[/editline]

Ok, fixed the first problem, now just need help with caustics not showing.

[editline]18th May 2011[/editline]

Hmm, great new problem, now that I’ve coded my water, it appears a block of white and doesn’t animate.

“Water”
{
“$abovewater” 1
“%compilewater” 1
“$forceexpensive” 1
“$reflectentities” 0
“$envmap” “env_cubemap”
“$refracttexture” “_rt_WaterRefraction”
“$refractamount” “0”

"$bumpmap" "Water/water_awsome_bump"
"$normalmap" "Water/water_awsome"

"$surfaceprop" "Water"
"$bottommaterial" "Water/water_awsome"
"$bumpframe" "0"

"$reflecttexture" "_rt_WaterReflection"
"$reflectamount" "2"

"$fogenable" 1
"$fogcolor" "[99 214 225]"
"srgb$fogcolor" "{63 214 225}"
"$fogstart" -1024
"$fogend" 90

}

That’s the code. In hammer the underside of the water texture shows the water but the surface is all white,

Well for the animate you need to add


	"Proxies"
	{
		"TextureScroll"
		{
			"texturescrollvar" "$bumptransform"
			"texturescrollrate" .01

			"texturescrollangle" 25.00
		}
		"WaterLOD"
		{
		}
			
	}

}

to the vmt

I honestly can’t tell everything you are doing exactly, do you have an animated normal map or no?

Yeah, its animated aswell

[editline]19th May 2011[/editline]

This is my code so far:

“Water”
{
“$abovewater” 1
“%compilewater” 1
“$forceexpensive” 1
“$reflectentities” 0
“$envmap” “env_cubemap”
“$refracttexture” “_rt_WaterRefraction”
“$refractamount” “0”

"$bumpmap" "Water/water_awsome_bump"
"$normalmap" "Water/water_awsome"

"$surfaceprop" "Water"
"$bottommaterial" "Water/water_awsome"
"$bumpframe" "0"

"$reflecttexture" "_rt_WaterReflection"
"$reflectamount" "2"

"$fogenable" 0
"$fogcolor" "[99 214 225]"
"srgb$fogcolor" "{63 214 225}"
"$fogstart" -1024
"$fogend" 90

proxies
{	
	"AnimatedTexture"
	{
		"animatedTextureVar" "$basetexture" 
		"animatedTextureFrameNumVar" "$frame"
		"animatedTextureFrameRate" "1"
	}
	"WaterLOD"
	{
	}
}

}

I haven’t used texture scroll however, but I will add it when it works.

[editline]19th May 2011[/editline]

Ok, hopefully last update. This is my texture now. It animates, but the surface both in hammer and ingame is white.

“Water”
{
“$abovewater” 1
“%compilewater” 1
“$forceexpensive” 1
“$reflectentities” 0
“$envmap” “env_cubemap”
“$refracttexture” “_rt_WaterRefraction”
“$refractamount” “.32”
“$refractblur” “1”

"$scale" "[1 1]"
"$bumpmap" "Water/water_awsome_bump"
"$normalmap" "Water/water_awsome"

"$surfaceprop" "Water"
"$bottommaterial" "Water/water_awsome"
"$bumpframe" "0"

"$reflecttexture" "_rt_WaterReflection"
"$reflectamount" "2"

"$fogenable" 0
"$fogcolor" "[99 214 225]"
"srgb$fogcolor" "{63 214 225}"
"$fogstart" -1024
"$fogend" 90

"water_awsome"
{	
	"$fallbackmaterial" "Water/water_awsome"
}
proxies
{	
	"AnimatedTexture"
	{
		"animatedTextureVar" "$normalmap" 
		"animatedTextureFrameNumVar" "$bumpframe"
		"animatedTextureFrameRate" "24.00"
	}
	"WaterLOD"
	{
		"dummy" 0
	}
}

}

What is



"water_awsome"
{
"$fallbackmaterial" "Water/water_awsome"
}

get rid of those

Also use code tags.

Have you tried turning fog on?


"WaterLOD"
{
 **"dummy" 0**
}

Why is that there? get rid of dummy 0

Ok, removed those codes, fog is enabled but it still appears as white

[editline]20th May 2011[/editline]

Fixed the problem, turned it into a refract and it works