Texture Overriding/Not being there...

Where do I begin. I’m incredibly new to the sort of taking files. Fiddling with them and sending them back on their way, so bare with me here.

I recently decided that the textures on a certain pack of weapons were not enough for my needs so I made a new texture. Ripped out the .gma over wrote the texture file in it. Renamed some folders/files. Altered the words in the .vmt file. Changed a bit of the .lua to the corresponding sh*t that it has to be. And i’ve shown a lot of people this. To be honest they couldn’t see what I couldn’t either. Hence me turning to good ol’ Garry’s forum. Curious to know why. If I do get my texture to work it will over ride every single weapon that was in the original pack. Or, or. It just will remain its old black standard edition oldness.

One thing I couldn’t find is where the command or call or what ever calls the texture to be on the model. I figured if I could find that then I could change some more folder paths and get it to stop killing my other weapons. (If I change the path the weapon will simply turn invisible).

Any ideas. Please. Help? Links? No? Okay :frowning:

The “calls” you’re referring to are compiled into the model itself. Your two options are decompiling the model with a tool called Crowbar and editing the newly generated QC file with a text editor (Notepad or Notepad++), then recompiling the model, OR you could use a Hex code editing program to “hex” the paths in the mdl file. I would suggest the first, only because bad things happen if you screw up the hexing process.

For example, if the original VTF was named generic_diffuse.vtf, and it’s corresponding VMT was called generic.vmt, generic.VMT would look like this:



"VertexlitGeneric"
{
    "$basetexture" "models\weapons\etc\whatever\generic_diffuse"
    "$bumpmap" "models\weapons\etc\whatever\generic_normal"
}

Now if you made a new VTF called mytexture.vtf, all you would have to do is change the “$basetexture” line from what it is to:



"VertexlitGeneric"
{
    "$basetexture" "models\weapons\etc\whatever\mytexture"
    "$bumpmap" "models\weapons\etc\whatever\generic_normal"
}

and everything should work properly.

If you’re still getting issues, post your VMT with [noparse]




[/noparse] tags and someone can look at it here.