Texture Stretch Problem (not purple and black)

Dear facepunch,

I have a bit of a dilemma. I am using a temporary computer. The computer is terrible. It has a major graphical glitch when decals are applied to something, for instance when you shoot at a wall, the bullet hole decal goes where you shot. Except, this computer spazzes out and applies every decal there, or just a bunch of dots. Also, blood stains seem to stretch all the way until the map origin. Any ideas?

Pics.

Uberspaz.

http://filesmelt.com/dl/gm_flatgrass000325.jpg

Stretch to origin example.

http://filesmelt.com/dl/gm_flatgrass000418.jpg

All decals in one 1

http://filesmelt.com/dl/gm_flatgrass000526.jpg

All decals in one 2

http://filesmelt.com/dl/gm_flatgrass000621.jpg

This really needs to be solved because when looking at the spazzed out decals the FPS drops super low.

Thanks.

Oh, forgot. Specs:

Compaq Presario
AMD Sempron Processor, 1.81ghz
1.31gb RAM
And an old integrated graphics chip.
(all drivers are up to date)

Yep the same typical issue seen with older intel integrated graphics chip as well. Is the integrated graphics in that the SIS Mirage2 Graphics chip ? if it is it supports DirectX 8.1, Shader 1.3

Try the following launch options
-dxlevel 81 or
-dxlevel 80 if the first don’t work.

That should fix the issue. you might want to use Directx 8.0 (-dxlevel 80)

Well, I am already running in dx8 mode. I haven’t tried dxlevel 81 but I doubt that would make it better. Any other ideas? But yes, it is an SIS chipset, but I cant remember if it is mirage or not.

well darn, it was worth a shot, if dxlevel 80 is still not doing things well then dxlevel 81 will just make things worse. Have you checked to see if the driver is up to date ?

have you tried -autoconfig launch option just to see if it will correct the issue.

have you also tried windowed mode launch option (-windowed)

have you made sure that all settings are set low as possible ?
I am afraid that there might not be much you can do to correct the issue with this old crappy integrated graphics chip.

Alright, I will try these and get back to you.

[editline]27th May 2011[/editline]

None worked :frowning:

The system does not even meet the (real) minimal requirements, I’m surprised you can run the game at all.

Unfortunatly, look like you are stuck with what you have untill you can get a better system, just be glad it works.

I think I have an idea. Do you remember the slider that you can adjust max decals? Well my problem consists with applying decals, so if I changed the slider to zero, I might possibly get those decal errors to go away.