Texturel fail, Whats wrong?

Hello, I made my map with blender and got my textrue on it. But then i was done i notice that I cold see the model behind the actually model.

Heres a Image, please take a look:
http://cloud.steampowered.com/ugc/1137419435345592171/728E98E9DEC523452F32CF8AD4681378E26CAC73/

[editline]24th November 2012[/editline]

Found out that if I use texture/Metrail tool on the model. It goes away so it must be the texture.

[editline]24th November 2012[/editline]

I still have problem though

you have a transparent texture without compiling with $opaque

What does it mean?

This is my QC file:

//////////////////

$modelname “Box_YDE/Box_YDE.mdl”
$cdmaterials “models/Box_YDE”

$scale 1.0
$surfaceprop “Wood”

$body “Body” “Box_YDE.smd”

$sequence “idle” “Box_YDE.smd” fps 30

$collisionmodel “Box_YDE_collision.smd”
{
$mass 40
}

//////////////

Should i do like this?:

$modelname “Box_YDE/Box_YDE.mdl”
$cdmaterials “models/Box_YDE”

$scale 1.0
$surfaceprop “Wood”

$body “Body” “Box_YDE.smd”

$sequence “idle” “Box_YDE.smd” fps 30

$collisionmodel “Box_YDE_collision.smd”
{
$mass 40
$opaque <---------------------------------------------------------------------------- Here
}

///////////////

Please anyone? :frowning:



$modelname "Box_YDE/Box_YDE.mdl"
$cdmaterials "models/Box_YDE"
$opaque
$scale 1.0
$surfaceprop "Wood"
$body "Body" "Box_YDE.smd"
$sequence "idle" "Box_YDE.smd" fps 30
$collisionmodel "Box_YDE_collision.smd"
{
$mass 40
}


Try that. Admittedly you should just replace the $translucent in the material. Doesn’t look like you need actually need transparency.

The $opaque command is for the .VMT, not the .qc you used to compile.

But if $opaque is used in the .vmt file. What should i type then?

“VertexlitGeneric”
{
“$basetexture” “models/BoxN2/BoxN2”
“$translucent” 1
“$opaque”
}
This?

[editline]24th November 2012[/editline]

Nothing of all this helped me…
Heres my files as they are right now.

.vmt file:
“VertexlitGeneric”
{
“$basetexture” “models/BoxN2/BoxN2”
“$translucent” 1
“$opaque” 1
}

.qc file

$modelname “BoxN2/BoxN2.mdl”
$cdmaterials “models/BoxN2”
$opaque
$scale 1.0
$surfaceprop “Wood”
$body “Body” “BoxN2.smd”
$sequence “idle” “BoxN2.smd” fps 30
$collisionmodel “BoxN2_collision.smd”
{
$mass 40
}

[editline]24th November 2012[/editline]

OKAY FOKES!!!
I GOT IT!! :smiley:

Delete the “$translucent” 1 in the .vmt file!