Textures don't show in-game.

I am using Blender
Hello, I am writing this due to me having a problem with the textures showing in-game.
I have followed a tutorial on how to rig etc. (I’m really bad at rigging and weight painting)
I opened my model that I wanted to rig, applied the textures that came with it into it’s appropriate places (I got told to just drag and drop .png files on the meshes and it should work) on the meshes and then I joined all the meshes together then rigged it to a valvebiped skeleton, After doing all of this I have turned it into a .smd, Changed the QC to fit mine, I checked if the materials tab was in the right place and I put it into the addons of gmod, I go in-game it all appears with the right name I wrote in the lua section, the model seems to look like the one I rigged but it shows Black and Pink textures, I have went into the VMF and VTF files and checked if it is all into the right place and it is all in the right place with the correct base texture in the VTFedit files.
It all still appears to be black and pink textures meaning it should be the materials…
I was told to drag and drop the .png images that came with the model onto the meshes in the blender and then just name the VMF the same as the texture I dragged and dropped onto the model…
I don’t know what I’m doing wrong, Please help.

Anyone that can help me with this? I’ve been trying to figure out the reason it shows black and pink textures but I still have no idea, I checked multiple times the VMT and FTF and my .qc to fit it but no luck… Anyone?

I have no real idea how it works, but when I’m applying textures in Milkshape I apply the VTF. Maybe try setting the model up to look for the VTF file instead of a PNG?

Again, just a whim, I don’t really know how it works.

As a rule of thumb, check this stuff off the list because you probably made a mistake at one of these stages:

  1. The model’s material has a name in blender
  2. The VMT’s name matches the material’s name. Remember, the game Looks for the VMT with the same name as the material, and it’s the VMT that points the game to the VTF which has the actual texture.
  3. The QC’s $cdmaterials is pointing to the correct folder, and does not include the word “materials” in the texture path (eg of a correct path would be “Folder\Folder”)
  4. The VMT and VTF are placed in the correct folder
  5. The VMT’s code is pointing to the correct file. Make sure the materials folder is not included in the path and that the VTF’s name is correct and matches with the file (eg of a correct path would be “Folder/Folder/VTFName”)

Good luck!