"Textures exceeded MAX_MAP_MIPTEX" error compiling GoldSrc map

I’m trying to compile a map for Half-Life 1. I’ve only textured half the map and I’ve already exceeded the texture limit.

Is there a way to increase this limit? I’ve heard that you’re supposed to add “-texdata #” somewhere but I can’t find out where that is.

[editline]__[/editline]

I figured it out, since every google result for this error doesn’t result in any sufficient answers I’ll put it here:

“-texdata #” only works with ZHLT’s build programs.

Download those, go to “Tools>Options>Build Programs” and replace the .exes with the ones from ZHLT.

Go to build by pressing “F9”. When the window pops up, click “Expert” in the bottom left corner.

In the lefthand list, select the item that starts “$csg_exe”, go to the righthand textbox under “Parameters” and type in “-texdata #”.