Textures not showing up in hammer

I made some custom textures for ep2 and when I put them in the materials folder it doesn’t appear in hammer, but my other texture I have in there which has the same code works. What the fuck is going on here?
Also here is the code


"LightmappedGeneric" 
{ 
    "$basetexture" "/floor01.vtf" 
    "$surfaceprop" "wood"
}

remove the / in the basetexture line

and make sure the .vtf is places here:
Half-life 2 Episode 2/ep2/materials/floor01.vtf

Didn’t work, and that’s were I placed it.

Remove .vtf from the VMT.

Nope, didn’t work.

Is the floor01.vtf and floor01.vmt in this folder:
half-life 2 episode two\ep2\materials

And does the .vmt have this:
“$basetexture” “floor01”

and are you sure you are using ep2 config in hammer?

Yes, yes, and yes, everything is right, as I said before I have another custom texture in there working and I can see it in hammer, I’m trying to add these new ones but it won’t show up.

then maybe the .vtf is fucked?

as in invalid data or whatever you want to call it

That’s what I’m starting to thing, but all 8 textures are corrupt?

I just recompiled that working texture with the same settings and it still works, maybe hammer just hates me?

Confirm that the *.vmt is *.vmt and not *.vmt.txt?

heh look at that it was vmf god damned letter :argh: