TF2 Maps Usually Not Appearing in List

I’ve had a weird problem since GMod 13 when live. Most of the time when I start a new game and select a map, the TF2 folder is there, but it only lists one map, that custom-made cp_baseball or something I downloaded a while back. I tried verifying TF2’s cache, and that didn’t help. Sometimes the rest of the TF2 maps are available, but I can’t pinpoint what’s making it fail to mount them. Has anyone else had a problem like this? Nothing’s happened to any other TF2 resources, just the maps.

Seven steps to always do when you have a weird problem that you can’t resolve and nothing has worked, obviously when Gmod is closed:

  1. Make sure game is mounted.
  2. Unsubscribe to all addons via the Workshop.
  3. Delete your garrysmod/ folder. (not your root, the folder right after steamapps/[username]/)
  4. Start Garry’s Mod, exit game and then verify game cache for both it and TF2.
  5. Go back and make sure the game is still mounted, and check to see if you problem is still there.

If none of this worked, including reinstalling both gmod and tf2, no idea your issue. Just make sure TF2 is mounted via the little controller icon on the main menu.

For now, it looks as though the TF2 maps are being listed again. The only trouble’s gonna be finding all my addons again. Thanks for the help all the same.

I have this problem too. Did Valve fuck something up with Team Fortress 2? Because my guess is that some update or something happens and Garry deliberately gets rid of the TF2 maps to fix them up or some crap. If he is, then I’m not complaining, but I doubt this is the case.
Also, what workshop addons did you uninstall? I might be able to find an addon we both have that may cause the problem, because I don’t want to uninstall a shitload of items and have to reinstall them all again.