The command failed. Windows reported the error: "The system cannot find the file specified."

Evey time I complie, I get this error:
The command failed.Windows reported the error:“The system cannot find the file specified.”

Compile Log:




** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\bin\vbsp.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\ep2" "C:\Users\Vrej\Desktop\gm_vj_test.vmf"

Valve Software - vbsp.exe (May 15 2014)
8 threads
materialPath: C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\ep2\materials
Loading C:\Users\Vrej\Desktop\gm_vj_test.vmf
Could not locate 'GameData' key in c:\program files (x86)\steam\steamapps\common\half-life 2\ep2\gameinfo.txt
Patching WVT material: maps/gm_vj_test/nature/blendashdirt01_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing C:\Users\Vrej\Desktop\gm_vj_test.prt...Building visibility clusters...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_ep01_04*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_ep01_04*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Overlay touching too many faces (touching 118, max 64)
Overlay decals/trashdecal03a at -4022.0 -3794.1 -2399.0

** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\bin\vvis.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\ep2" "C:\Users\Vrej\Desktop\gm_vj_test"

Valve Software - vvis.exe (May 15 2014)
8 threads
reading c:\users\vrej\desktop\gm_vj_test.bsp
Error opening c:\users\vrej\desktop\gm_vj_test.bsp

** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\bin\vrad.exe"
** Parameters: -both -game "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\ep2" "C:\Users\Vrej\Desktop\gm_vj_test"

Valve Software - vrad.exe SSE (May 15 2014)

      Valve Radiosity Simulator     
8 threads
[Reading texlights from 'lights.rad']
[48 texlights parsed from 'lights.rad']

Loading c:\users\vrej\desktop\gm_vj_test.bsp
Error opening c:\users\vrej\desktop\gm_vj_test.bsp

** Executing...
** Command: Copy File
** Parameters: "C:\Users\Vrej\Desktop\gm_vj_test.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\ep2\maps\gm_vj_test.bsp"

The command failed. Windows reported the error:
  "The system cannot find the file specified."




Overlay touching too many faces (touching 118, max 64)
Overlay decals/trashdecal03a at -4022.0 -3794.1 -2399.0


This is the error you need to focus on.

If you don’t need to resize the decal, you should use infodecal instead of an overlay. overlays are more expensive to render and if you have too many in an area it can cause performance problems.

This map is for Garry’s Mod, therefore I can’t use infodecal.

There’s the Decal tool, and the Overlay tool. (at the left toolbar)

In hammer?

Yes, Decal tool uses this icon:

while overlay tool uses this:

The decal tool creates the “infodecal”

Uh, what makes you think infodecal doesn’t work in Garry’s Mod?

infodecal has always worked in Gmod.

No it works and spawns, but when you cleanup the map it duplicates. So let’s say you clean up the map now you have 6 of the same decals. Every time you cleanup the map, it spawns another one. so let’s say there was 4 decals in the map, you cleanup now there is 8 then there is 16 then there is 32.

~ Sorry for my bad english.

Did you try restarting your computer?

Yes it’s the same thing, I will try it again today and see if it is fixed from the latest Garry’s Mod update.

I’ve never seen that happen and I’ve been playing and hosting Gmod since 2005. If Gmod is doing that, you should file a bug report. If you’re using a custom Lua script to do map cleanup, get the author to fix the problem, fix it yourself or don’t clean up decals when doing a map cleanup.

No, cleanup all cleans everything, you can’t just pick to cleanup everything except decals.