The gamje is currently unavaliable at this time

Whenever I try to run gmod I get this message. I have reinstalled steam, reinstalled gmod, and still it says this. It’s not a “hidden” hl2.exe in the backround either.
Specs:
Amd Athlon 64 x2 dual core processor 4200+ mmx, 3dnow (2 cpus)
Ati Radeon x1200
2g of ram

Maybe it didn’t install correctly? Or it is still Evening out the updates. I can’t help you much.

Restart STEAM/Computer and try again. Or try updating STEAM and Garry’s Mod.
Maybe check if you have the needed SOURCE game installed as well. You need it installed for GMod to work.

I am in the process of reinstalling hl2, portal, ep1 and ep2. Also reinstalling gmod a 2nd time, if this doesn’t work I don’t know what will.

I did that, and it still does not work! I don’t understand this It was working fine 2 days ago!

is it just gmod that gives you this error?

Try to delete steamapps\your_username\garrysmod (THROUGH WINDOWS EXPLORER,


NOT

STEAM).

Does Windows throw up an error when it tries to delete?

That’s how I always reinstall, because I don’t trust 3rd party methods of removal =P
No but it’s working now, stupid me after I reinstalled gmod and hl2 I restarted and it starts up fine now.
Thanks for all the help, but it was mostly my stupidity.

Edit:

That was wrong, apparently it only works in offline mode. I don’t get this… any ideas?

Ha Ha Ha
It should work, no one knows the cause of this. Reinstalling anything will not work. Guaranteed
This is mostly a server-side issue, so my advice, is at max, restart computer, and if it doesn’t work, go outside and kick a ball around.

Delete clientregistry.blob in the steam directory, start up Steam.

SOrry, what I meant was, it works ONLINE in offline mode but won’t use the web browser and stuff in game. Nor update, and stuff like that.

Are you kidding me? Did you not even read my original ,unedited, post? I so obviously did that in the process of installing steam I don’t even know why you would post this.

Nowhere in this thread does it indicate you have tried deleting the clientregistry.blob, therefore no because I never saw your “original unedited post”, How the hell am I meant to know you did that in the process of installing steam, I can’t read your fucking mind, I was trying to help Jeez…

Not to mention he needs to do it now, not during or… straight after installation?

Actually Yeah, you do the old delete the clientregistry after you install steam…

At this point, it sounds like SOMETHING is trying to do SOMETHING to one of Garry’s Mod’s core files.

I had an issue where some process or other would obsess over my garrysmod/bin/unicows.dll (or something like that) and I had to kill it for Steam to be happy with me again.

Close Steam and run it with the -console parameter. Steam should make a new tab (labeled “CONSOLE”). Launch GMod from Steam as you normally do and WATCH THE CONSOLE. When you get your Game Is Unavailable error, the console SHOULD give a line (kind of) explaining what the fuck is going on.

Sorry to get mad, you were right. I was thinking of another thread I made on a diff forum. Anyways, I uninstalled steam by deleting the whole entire steam folder, then starting over. So the clientregistry.blob went with it.

Where do I put the -console? I tried it with the shortcut and it didn’t do anything.
Never mind, I forgot the space. Doing it right now.

[editline]11:27PM[/editline]

It says, “resource failed verification check”.
I validated the local files and it was successful. But it still is saying that.

That means something or other is fubar. You already said the Garry’s Mod Verify was returning OK, so that makes me think Steam itself is, as the ol’ Disney character Goofy would say, “ker-skuffled”. (I always wanted a reason to say that)

Go into your Steam folder (the main one) and delete everything EXCEPT:

  • Steam.exe
  • the Steamapps folder

Then run Steam.exe (it will redownload what it’s missing)

And you do have a REAL COPY of the game, right?

[editline]05:12PM[/editline]

If you do, uninstall Steam, delete any remaining portion of it (like in program files), then reinstall. If this does not work either, try checking the internets. :slight_smile:

“Well, gee. He knows what Verify In Steam means, he’s giving a valid answer to the question of what the Steam console’s output is…I think he’s a pirate!”

/facepalm

Ignore him, let’s move on.

Well, I didn’t know that pirates couldn’t do these things.

Here is an article from Steam, looks like THEY caused it?