The moving character/screen/camera problem

Evening all,

I have a problem with Garry's Mod, which appeared after a recent format of my laptop. Whenever I try playing online or offline (no matter if I join a server or start my own) my entire camera/characters keeps turning in any direction constantly. 

 To be more exact, when the game starts off, everything is fine, I start walking about and then my mouse begins flashing in the middle of the screen (where the crosshair is). If, while it flashes I try moving the mouse about it will "freeze" in that position, making my camera turn in that direction constantly (the speed being dependent how far is it from the centre, and what mouse sensitivity is set). Each time I move the mouse around, while it flashes, the direction in which the screen will turn, will change (depending where the mouse stops, once the single blink stops). 

 Now, when I start typing (to send a message) turn on the options or console, the mouse behaves normaly, and the character/camera will stop turning. I did notice however that if I press tab, showing the player list (on some servers/offline) the mouse will persistantly go back to the place where the "panning" is caused from. So, if the camera keeps moving right, when pressing tab the mouse pointer will be somewhere on the right, and although I can move the mouse it will snap back to that very point all the time.

Also, when pressing the Q button to spawn props the menu will be forced-closed in what one would call a blink of an eye. (more or less as quickly as the flashing mouse icon is) 

Before the format the mouse/software worked perfectly fine, and back then I did not have all the necessary updates. This problem also seems to appear only in Garry's Mod. I checked for similar problems but they usually pointed at gaming pads being connected to the laptop/PC (I do not have them). Another problem which *might* be related is that my CS:S when I tried it offline recently keeps on opening the Buy Menu when I am in the starting buy zone. And when I leave it, even when I am not pressing anything, the game is still assuming I want to open the buy menu. 

This might be a problem with the drivers, since I tried updating everything to the highest possible standard, on the other hand I noticed the problem still before I made all the driver updates, however, after I upgraded to Vista SP 2. I did not try the game between finishing of the format and upgrading to SP 2 though.

Any help would be greatly appreciated, if any specific info is needed I will provide.

[editline]4th November 2010[/editline]

I have found the cause, please lock/delete this topic.

You still should write, what did you do to fix it. Some people might want to know.

im guessing he Pressed Alt and Tab then clicked back into the game, that might work