"The system cannot find the file specified."

Aight real nigga hour here boys.
I’m now using the proper gmod configuration for hammer now (the one in garrysmod\bin) and upon compiling the smallest and most elementary of maps I get this error:

** Executing…
** Command: “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\bin\vbsp.exe”
** Parameters: -game “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod” “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod\maps\structures.vmf”

Valve Software - vbsp.exe (Mar 14 2016)
4 threads

** Executing…
** Command: “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\bin\vvis.exe”
** Parameters: -game “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod” “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod\maps\structures”

Valve Software - vvis.exe (Dec 9 2014)
4 threads
reading d:\program files\steamlibrary\steamapps\common\garrysmod\garrysmod\maps\structures.bsp
Error opening d:\program files\steamlibrary\steamapps\common\garrysmod\garrysmod\maps\structures.bsp

** Executing…
** Command: “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\bin\vrad.exe”
** Parameters: -both -game “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod” “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod\maps\structures”

Valve Software - vrad.exe SSE (Dec 9 2014)

  Valve Radiosity Simulator     

4 threads
[Reading texlights from ‘lights.rad’]
[45 texlights parsed from ‘lights.rad’]

Loading d:\program files\steamlibrary\steamapps\common\garrysmod\garrysmod\maps\structures.bsp
Error opening d:\program files\steamlibrary\steamapps\common\garrysmod\garrysmod\maps\structures.bsp

** Executing…
** Command: Copy File
** Parameters: “D:\Program Files\SteamLibrary\steamapps\common\GarrysMod\garrysmod\maps\structures.bsp” “D:\Documents\Files\Hammer\TESTING\Structure tests\structures.bsp”

The command failed. Windows reported the error:
“The system cannot find the file specified.”


I’ve never encountered a problem like this. The file name is definitely safe.
The bsp is nowhere to be found after vbsp.exe. (I looked.)
It’s possible I’ve overlooked something retarded.

Cheers fellas.

hmm not much info in the log can you give a link to ur vmf ? also are you using the expert option to compile the vmf ??

I’m not using expert mode no. I also reinstalled garry’s mod in case the vbsp.exe was broken for whatever reason.
It’s a tiny file: https://www.mediafire.com/?4avsqvd55nx533l

compiles ok switch to expert option and try again :slight_smile: small indeed :confused:

No luck on expert either my dude
Are my settings alright? http://puu.sh/qWdNk/64b7cb3ff0.png

yes things look ok, try resaving it as a new name in the maps folder then compiling using expert

Same error ;(

really strange, do you have the sourcesdk 2013 mp installed, if you do try compiling using that if you get the same error then it could be your antivirus is stoppng vbsp from running, aprt from the small size of your level theres nothing wrong with it, you could a larger map “remove the sky and make 3 or 4 rooms with a light in each and maybe a small prop and try that”

My hammer for counter strike compiles properly if that’s worth noting.
I’ll try making a skyless map and also try with source sdk 2013 mp.
Thanks for the help.

Ah shit I figured it out. At some point I must have changed the directory for the bsps to go in my gmod config. I feel dumb. Thanks for helping me out dude.