The tools don't work when used on the map.

Pretty simple. The tools don’t do anything when used onto the map.
They can point or shoot at it, but nothing happens.
The ghost/outline appears, but nothing happens.

Here’s a video just so you get the point:

This happened after I downloaded some (trusted) addons. It happened to me before, and I’m 100% sure the addons aren’t corrupted or anything, though if I remove all of the addons, the tools will work, but if I put them all, or most of them back again, the tools don’t work anymore.

Actually, this is a rare problem and I have no idea what causes it to happen. I fixed it once by putting in my addons ONE BY ONE by starting the game after I did, but it was long and painful.

Does anyone have any idea of what causes this to happen?

What are these trusted addons? And sorry to burst your bubble but if the problem occurs after installing the addons and works without, put 2 and 2 together. There has to be a problem with one or more.

SCars and a few player models I have used before. I’ve tried just what you said and it did work, but it took ages.

In the end, I put in all of the addons and none caused that problem. I have just no idea what causes this.